Alpha Problems...

This problem passes from the version 2.46 onwards.
When I push the OSA button, the foliage of the trees seem fried eggs! something wrong happens with alpha channels.

this is the .blend file to see what I’m talking about.
Thanks in advance!

Answered here, see post #2: http://blenderartists.org/forum/showthread.php?t=138890

Activate ZTransp under Shading panel–>Links and Pipeline. Also check the Alpha slider under Shading panel–> Material tab–> A (set to zero).

But yeah, the bright green and red artifacts are disturbing. I thought something was amiss.

Don’t forget to “premultiply” the texture: the “premul” button in the textures/image panel. This takes care of most of the nastly edge artifacts surrounding alpha-mapped images.

thanks guys, but the problem persists despite the new tips

2.45
2.48

Hi,
if you are using Gimp, the problem can be avoided if you uncheck “save background color” when saving your texture (see Gimp docs, scroll down to “1.2.3 Saving as PNG”). EDIT had to disable “Save color values from transparent pixels” too, background color alone does not do the trick.

I did that with one of your textures and the result seems fine, see 1st and fourth tree from right:

Seems like Blender’s oversampling incorrectly (?) includes the background color… bug or feature?

Hope it helps, happy blending!

Huh…what you have there are some nice Burning Bush models.:smiley:

OK, groping around here:
-try turning down the spec to 0; actually, anything that wants to make the plane object itself render (as opposed to the image) should be 0 or off. Careful, though: you still want the shadows beyond.
-click on the “clip” button in the texture/map image panel, which sets everything outside the image area to 0 alpha

EDIT: oops, looks like MPPIC got in with a solution before I posted…either way, the above ideas are useful with alpha images in most cases.