Alpha Texture being lit while in shadow

I’m following Andrew Price’s video on How to Create a Realistic Earth in Blender. I’ve made it all the way to 19:20 in the video, then I run into a problem when checking Transparency and changing the “Z Transparency” Alpha to 0.

Using Blender Render


The texture is applied to a UV Sphere that is scaled up just a bit larger than the base sphere that the terrain is sitting on.

I get weird lighting of the clouds on the dark side of the Earth. This only happens if the texture is transparent, but obviously the clouds need to have transparency so that the terrain is showing.

I feel like I’ve tried everything but I can’t seem to get rid of it…

The same thing is happening to the next sphere added, the “Atmo-sphere.”


I’ve tried using the same method used to reveal the night lights in the dark but it yields the same results.


have you tried to check the ‘clamp’ option in your mix node?

Actually I figured it out!

Originally my “Sun” was a spot lamp, which I then changed to a sun in the properties pannel. When you do that you need to make sure that under Sun > Shadow that “Ray Shadow” is selected and not “No Shadow.”