alpha textured faces disapering if front of other... (now whit .blend inside)

well is a little hard to explain but I’m having a problem whit alpha texturef faces disappearing after one faces appears in from of the others on Game engine.

the attachment is to make it more visible. the 1 is before pressing P and the 2 is after. The circled thing is an example of the faces disappearing…

what happens is: that blurry background on my scene is an mesh whit an alpha texture. previously i used to press P and the blurriness of alpha channel on the texture wold disappear making it looks really bad. Then i discovered that little button “alpha” that appear on the Editing panel only wen we are whit an UV selection window open. i tryed that and the result was really nice… the nuances of Alpha came back. So i put that on my other alpha textured objects since they also are looking bad. Then afther the P guet pressed the faces of the objects that used to be in fornt of the background simply disappeared… if i rotate the camera making them gueting away of the background, they appear once again.

anyone have a clue about how o solve this? i’m really don’t want to disable that option if possible, since it makes my alpha textured meshes look so much better…

EDIT: Blend file can be found here. Please take a look.

http://www.savefile.com/files/1158853

Attachments


Hi!
I’m not sure that’s gonna work but I think that if you enable the Ztransp option (material->Links and Pipeline pannel) the problem will be solved…
Hope this help

I already tried that but, unfortunately it didn’t solved the problem…

it might have to do with looking at back faces, try flipping the faces on the model and see if that helps.

hi, got the same problem and solved by enabling the Ztransp option. why not yours?:confused:

Question is if you have enabled “Use blender materials” or not…
Can’t test it right now but my guess is that it has something to do with it.

Mmph!: his may not be the case since those faces are all w-sided…

Colin: i really want to know why…

acestrudel: well… i actually don’t know were enable “Use blender materials”. But doesn’t it make the performance go much slower?

tanks on the feedbacks everyone… this problem is kinda making me sad!

it could be an issue with alpha sorting. Alpha sorting issues happen when the rendering engine isn’t sure how to display overlapping alpha maps. But normally if thats the case the alpha is drop on one of the polygons. So … who knows lol.

Game-menu / Use Blender Materials

It has to be enabled for Z-sort to work. And yes, ZTransp decreases performance.

Actualy the Blender material options was already tuned on… turning it of also does not work…

gez… can it be related wit my CPU video card?

You might still check the 2 sided… make sure that all the faces are 2 sided. And, sometimes if the normals get flipped even with 2 sided, it does strange things.

For instance on a model i had, you actually were looking through one side, and seeing the image on the other side.

I thought I was looking at the first side all the time. But if you rotated around it at all, then that side vanished and you could see you were looking at the second side.

It was an odd thing. I actually left it that way. LOL

But i used my weekend trying to solve it, checking all the suggestions, But I wasn’t able to solve the trouble.

So i decided to post an .blend file whit the meshes that are having trouble.

http://www.savefile.com/files/1158853

Please, if anyone can download it and take a look…

I knew I’d heard something like this before. see this thread http://blenderartists.org/forum/showthread.php?t=100830&highlight=alpha and look at Monster’s reply. He says that the alpha order is determined by object centres and so if your trees centers are not where they should be there could be problems.

PROBLEM SOLVED! UHUUUU!

Thanks Larry-boy and everyone ho helped me.

Well… an quick report on what was happening: Indeed the problem was related wit the objects-centers. The trees centers was all OK but the main problem relied on the background blurry thing was made from an cycle mesh that evolved the hole scene whit the center in the middle of it. (those ho downloaded the .blend file can see it)

I could not simply change the center because that wold make the things go ok on one point of view but bad on other. So i split the mesh in four different meshes, used the “Center New” button on every one of them and: Tharãns! Problem solved!

now i disabled the “use blender material” option and the “ZTransp” button and it is still working fine!

once again, tanks everyone!