Alpha transparency with raytracing

Hello, I’m sorry if this has been asked already but I can’t find the exact same problem with the search.

I have a plane with .png texture that has black assigned as alpha channel. Is it possible to render with raytracing so the alpha part remains completely invisible and not casting shadows? It’s working fine until I move the plane close to other objects ie. ground and it starts casting shadows from the alpha part. Using Blender 2.54b/2.55b.

Thanks

For the object that is recieving the shadows you need to give it a material and select ‘Recieve Transparaent’ in the Material / Shadow panel.
It will then recieve transparent shadows. If the object casting shadows is completely transparent, the shadows also will be and you won’t see any.

Yes, I have set it but the problem still persists. I forgot to mention this is with Ambient Occlusion/Environment Lightning.

Edit: Ok, here’s a quick pic I made to demonstrate. Both planes have the same material while the left one casts shadow when close to the ground.


mmm, life, if you follow this…
http://blender.bencrowder.net/transparent-textures/
but then in ‘Gather’, select ‘Approximate’…

Ok, thanks for the replies. I have set up the scene like in that link but choosing Approximate kind of defeats my question about rendering with raytracing enabled. If you look at the pic I attached you can clearly see the object casting 2 shadows.

So anyone please got a solution for this?

Set ambient to 0 in the shading tab of the materials window.

Sorry, yes, my mind was somewhere else. I did give it a while using 2.55 last night, to no avail though…

That seem to work for the extra shadow when set on the shadow receiving object but then there is no detail in any dark/shadowed parts of the object. In fact the extra shadow is there even with no lamps at all in the scene… “Use Ambient Occlusion to add shadowing based on distance between objects” that’s the tooltip in Blender for AO. I don’t really know how AO works in Blender but could this possibly be a bug as a material which alpha is set to 0 should be invisible and not cast/affect any shadowing, right? :confused:

Argh this is really bugging my head hah, there must be some switch or workaround somewhere…

I meant to set ambient=0 on the plane with the alpha mapped image texture, not the receiving object.

Tried that in both 2.49 and 255b, didn’t seem to have any effect though. If you can show an example of that working, ie. the object casting shadows only from the visible parts and not from the alpha with AO/Raytrace enabled that would be helpful. Thanks.

You are right - when using raytrace option for ambient occlusion, you get the square shadow from the plane. But I never use raytrace - I always use approximate and there is no problem. Why don’t you use approximate?

Because when you use ray tracing properly, ooooh

Hi Tihachi! Did you find any solution for this problem because I too think this is a bug?!

Raytrace AO is the only way to use the sky texture option for environment lighting. this is extremely useful when you want to achieve something similar to imagebased lighting.

I’m interested in hearing the solution to this problem, too. I’ve bumped into this issue trying to model a fern plant. The AO shodows on the ground plane look horrible, because they ignore the alpha values on the ferns branches/leaves, but whatever I try I can’t get it to work properly.

is there any solution for this problem?