Alpha Trees - Render massive forests, fast!

Yes now it works. Thanks :+1:t2: :crazy_face:

Ah good, glad I could get there eventually :laughing:

1 Like

So in the end that addon and trees from Modular Tree addon works fine together right from the start?

No I have done the test here with Sapling tree Gen. Because it generates 2 objects (tree and leaves). You need to add materials and join the two (Ctrl+J). It also makes most sense because the final result is not right in front of the camera.
With Modular tree it looks a bit different. It generates particles for the so-called twig object (leaves+twigs). First you have to convert the particle system. Then join the instances (Ctrl+J). Then join this with the tree. Then you have to drastically decimate (modifier) or else there will not be enough memory when rendering the maps (on a normal system).
And that takes time, so it’s not handy. But the tree looks better. :joy:

1 Like

This is probably something I could work into the addon at some point, as it shouldn’t be too hard to automate

1 Like

Peraphs it’s better if Modular Tree itself can automate this process (if Maxime accept to add your snippet)

Yes for Sapling tree that would be nice but I personally have no problems with this workflow. For MTree you need the interaction for the decimate modifier which is probably better done right after converting the particle system. Maybe it even makes sense to decimate the twig object right away. The downside is that the steps take so long to calculate. I am very satisfied with your addon. Thanks again for that. :+1:t2:

1 Like

Well yes, If I get around to doing it, I could suggest it for that project, though I think he’s a bit preoccupied converting modular trees into its own C++ application.

Update 0.3.2

  • Added the first version of an asset importer

alpha_trees_0_3_1.zip

This is quite a basic implementation and I will be improving it very soon. The addon comes with only one tree built-in, so you will need to generate your own if you want to use more. As well as this, the materials are looking a little odd, but I have a fix for the and it should also come soon.

2 Likes

Update 0.4

  • Improved import, now has for easy selection
  • Fixed a bunch of bugs with files and filenames
  • Fixed bugs with incorrect scaling when generating trees
  • Completely redid a large part of the material to improve normal mapping and overall realism

alpha_trees_generator_0_4.zip (234.7 KB)

Hopefully at some point soon I can get round to generating proper thumbnails as well :slight_smile:

1 Like

Trying to use this (as its looks really useful, thank you for doing it) - however, I’m getting the following error:

Python: Traceback (most recent call last):
File “C:\Users\name\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\alpha_trees_generator_0_4\operators.py”, line 134, in execute
gen_functions.render_maps(self, context)
File “C:\Users\name\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\alpha_trees_generator_0_4\gen_functions.py”, line 911, in render_maps
setup_scene(self, context)
File “C:\Users\name\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\alpha_trees_generator_0_4\gen_functions.py”, line 741, in setup_scene
context.scene.collection.objects.link(object)
RuntimeError: Error: Object ‘Tree_Quercus-cerris_T_summer.003’ already in collection ‘Master Collection’

location: :-1

Am using version 0.4. I am using a tree from botaniq as my test subject. Any advice welcomed…

Thanks

Ah, thanks for reporting that, I’m not quite sure how you got that error, but this should fix it:
alpha_trees_generator_0_4_1.zip (210.8 KB)

Thanks - but still can’t get it to work (now when I click on render maps, an error is thrown - “Material is not applied to any geometry, can’t split mesh”… I must be doing something wrong.

Have you modified the botaniq tree? If not I would suggest starting a new blend file and starting over, as I just tested it on that tree and it worked well. If you have modified the materials, make sure that there is a separate material for the bark and leaves, and that both materials are applied to the correct geometry in the mesh.

Update 4.2

  • Just a small update so you can now edit the material settings in the viewport:

alpha_trees_generator_0_4_2.zip (211.5 KB)

I’m just stumbling onto this post after searching for mTree information - What you’re doing is delightful! I’m so exhausted from making my own tree-cards and yours are so whopping full of 3D info! Thank you for this :slight_smile:

Looking forward to chopping into this with serious intent tonight.

1 Like

Wow, thanks! It’s great to see that there are people who actually use this type of thing :laughing:
I also just got sick of making these manually, so this seemed like a better solution.
Hopefully it works for you, but if you get any problems just say!

Top to bottom, this is 4, 4-1 and 4-2 on clicking to activate the addon…
I’m no code guy but I see patterns in the errors - is this because of something in my 2.9?

Just to double-check, installs from .zip, right?

Hmm, that’s a very weird error, but it seems to be a problem with blenders API.
This should fix it though:
alpha_trees_generator_0_4_3.zip (211.3 KB)

1 Like

We have liftoff.
I’m embarrassed how excited I am.

Thank you.
I’ll report back when able.

2 Likes