Alphabetic keys don't work in blender (2.4 as well as 2.5 and 2.6) on Debian i686

Dear blenderers,

My brother has this problem with blender on his Debian Sid laptop with [Radeon Mobility M6 (but I believe it has 32 mb of memory, not as the link says).

I remember using blender very successfully on that machine, but now something changed there. He composed a debian bugreport on that, but there’s some mail problem which didn’t let him to send it. I decided to ask here first. I also repost the original bugreport with more details.

Content-Type: text/plain; charset=“us-ascii”
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Package: blender
Version: 2.59-1
Severity: important

I started blender, and tried to move a 3d object in a object mode by pressing
‘G’ and blender didn’t recognize it.
And this repeats when i press any letter (only alphabetic keys).
I’ve tried to change my layout from English to Ukrainian and in reverse, but no
result came up.
Restarting blender/user/computer also gave no result.
Similar problem i had in blender 2.49, and blender 2.61 downloaded from
I work on laptop, maybe that matters…

I also attach a blender terminal output (blenderTerminal.txt) and system-info.

– System Information:
Debian Release: wheezy/sid

  • APT prefers unstable
  • APT policy: (500, ‘unstable’), (500, ‘stable’)
    Architecture: i386 (i686)

Kernel: Linux 3.1.0-1-686-pae (SMP w/1 CPU core)
Locale: LANG=uk_UA.UTF-8, LC_CTYPE=uk_UA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages blender depends on:
ii* libavcodec53********************* 4:0.7.2-1+b1
ii* libavdevice53******************** 4:0.7.2-1+b1
ii* libavformat53******************** 4:0.7.2-1+b1
ii* libavutil51********************** 4:0.7.2-1+b1
ii* libc6**************************** 2.13-21
ii* libfftw3-3*********************** 3.2.2-1
ii* libfreetype6********************* 2.4.8-1
ii* libgcc1************************** 1:4.6.2-5
ii* libgl1-mesa-glx [libgl1]********* 7.11.1-1
ii* libglew1.6*********************** 1.6.0-4
ii* libglu1-mesa [libglu1]*********** 7.11.1-1
ii* libgomp1************************* 4.6.2-5
ii* libilmbase6********************** 1.0.1-3
ii* libjack-jackd2-0 [libjack-0.116]* 1.9.7~dfsg-1
ii* libjpeg8************************* 8c-2
ii* libopenal1*********************** 1:1.13-4
ii* libopenexr6********************** 1.6.1-4.1
ii* libopenjpeg2********************* 1.3+dfsg-4
ii* libpng12-0*********************** 1.2.46-3
ii* libpython3.2********************* 3.2.2-2
ii* libsamplerate0******************* 0.1.8-1
ii* libsdl1.2debian****************** 1.2.14-6.4
ii* libsndfile1********************** 1.0.25-3
ii* libstdc++6*********************** 4.6.2-5
ii* libswscale2********************** 4:0.7.2-1+b1
ii* libtiff4************************* 3.9.5-2
ii* libx11-6************************* 2:1.4.4-4
ii* libxi6*************************** 2:1.4.3-3
ii* python3.2************************ 3.2.2-2
ii* ttf-dejavu*********************** 2.33-2
ii* zlib1g*************************** 1:

blender recommends no packages.

Versions of packages blender suggests:
pn* yafaray* <none>

– no debconf information

Content-Type: text/plain; charset=“us-ascii”
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename=“blenderTerminal.txt”

AL lib: pulseaudio.c:612: Context did not connect: Access denied
File radeon_swtcl.c function r100_swtcl_flush line 325
Rendering was 1 commands larger than predicted size. We might overflow* command

Saved session recovery to /tmp/quit.blend

Blender quit

Content-Type: text/plain; charset=“us-ascii”
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename=“system-info.txt”

= Blender 2.59 (sub 0) System Information =


version 2.59 (sub 0), revision unknown. Release
build date: 2011-10-21, 14:18:26
platform: Linux
binary path: /usr/bin/blender
-fopenmp* -msse2* -msse -pipe -fPIC -funsigned-char -fno-strict-aliasing* -Wall
-Wcast-align -Werror=declaration-after-statement -Werror=
implicit-function-declaration -Werror=return-type -Wstrict-prototypes
-Wno-char-subscripts -Wno-unknown-pragmas -Wpointer-arith -Wunused-parameter
-Wwrite-strings -Wno-error=unused-but-set-variable
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -fopenmp* -msse2* -msse -pipe
-fPIC -funsigned-char -fno-strict-aliasing* -Wall -Wno-invalid-offsetof
build linkflags: -pthread
build system: CMake


version: 3.2.2+ (default, Dec* 2 2011, 11:20:09)
[GCC 4.6.2]
*** /usr/lib/blender/scripts/addons
*** /usr/lib/blender/scripts/startup
*** /usr/lib/blender/scripts/modules
*** /usr/lib/python3.2/
*** /usr/lib/python3.2/plat-linux2
*** /usr/lib/python3.2/lib-dynload
*** /usr/lib/blender/scripts/addons/modules


scripts: [’/usr/lib/blender/scripts’]
user scripts: None
datafiles: /home/wsa/.blender/2.59/datafiles/
config: /home/wsa/.blender/2.59/config/
scripts : /home/wsa/.blender/2.59/scripts/
autosave: /home/wsa/.blender/2.59/autosave/
tempdir: /tmp/


renderer:*** Mesa DRI R100 (RV100 4C59) x86/MMX/SSE2 NO-TCL DRI2
vendor:*** *** Tungsten Graphics, Inc.
version:*** 1.3 Mesa 7.11.1
*** *** GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color
*** *** GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract
*** *** GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture
*** *** GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array
*** *** GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip
*** *** GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_rescale_normal
*** *** GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp
*** *** GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp
*** *** GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_multitexture
*** *** GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat
*** *** GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix
*** *** GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color
*** *** GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic
*** *** GL_EXT_texture_lod_bias GL_NV_blend_square GL_NV_light_max_exponent
*** *** GL_NV_texgen_reflection GL_SUN_multi_draw_arrays
*** *** GL_ARB_texture_border_clamp GL_ARB_texture_compression
*** *** GL_EXT_framebuffer_object GL_EXT_texture_env_dot3 GL_MESA_window_pos
*** *** GL_NV_packed_depth_stencil GL_NV_texture_rectangle
*** *** GL_ARB_occlusion_query GL_ARB_texture_env_combine
*** *** GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3
*** *** GL_ARB_texture_mirrored_repeat GL_ARB_window_pos
*** *** GL_EXT_texture_cube_map GL_APPLE_packed_pixels GL_ARB_draw_buffers
*** *** GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_EXT_stencil_wrap
*** *** GL_MESA_ycbcr_texture GL_ARB_vertex_buffer_object GL_OES_read_format
*** *** GL_ARB_texture_rectangle GL_EXT_texture_mirror_clamp
*** *** GL_EXT_texture_rectangle GL_EXT_packed_depth_stencil
*** *** GL_ATI_texture_mirror_once GL_EXT_texture_env_combine GL_OES_EGL_image
*** *** GL_ARB_copy_buffer GL_ARB_robustness



Ok, the mail to debian bug tracking system was delivered, you can track the progress here: