ALT-B isn't working in 2.67

ALT-B is not hiding selection in 3D view Port, I am wondering is it a bug or may be the shortcut has changed?

To hide something you selected it’s H
ALT+H to unhide what is hidden

ALT+B is the View Clipping function, you click ALT+B , you click and drag a box and it will clip from view everything that is not inside of the box you dragged. ALT+B to unclip everything

Yes I know but the clipping ALT-B is not working with matcap display, otherwise it works.

You should report it there so the devs notice (don’t forget to mention that it does not work only when a matcap is enabled)
http://projects.blender.org/tracker/?func=browse&group_id=9&atid=498