Alt+H not unhiding

Well, like the thread title says. . . I can hide an object with H and I know that Alt-H is supposed to unhide it, but that’s not happening. I can restore an object to visibility by clicking the eye icon in the outliner window, and I’ve checked in user preferences to confirm that unhide is actually set to Alt-H. Being rather noobish, I’m at a loss as to what else to check. I’d appreciate some help with this . . . it’s not crippling, but it’s sure annoying.

1 Like

did you get the latest SVN ?

got 55198 and seems to work fine on windows!


I’m using the 2.66a that I downloaded from Alt-H works fine on my laptop with 2.66; I guess I should update to 2.66a there and see if the problem occurs there, too–that would point to a bug in the download version.

If I get the latest SVN, will I have to compile it myself? I’m not terribly confident in my ability to do that.

no need to complie it

just download SVN and unzip if locally in a folder


Welp, I downloaded the file at that link–the Windows 64-bit version–, extracted it, and ran it . . . H hides, Alt-H does nothing. I know it’s not my keyboard, because I tried the keyboard on another computer and it worked. I’m really confused.

check if the RNA var is set for Alt-H in the outliner section
this si default anyway

do you have any special setup or usrefile on your system ?
try in file menu to upload the default manufacture setting and see if it works!

it should work!


I haven’t got any special setup, and I tried the “load factory settings” option from the File menu . . . still nothing, and I checked under the User Preferences > Input > 3D View > Object Mode and found that the “Clear restrict view” is indeed set to Alt H . . .

Weird, if I set it to something else, like Ctrl-zero, or Shift-Ctrl-Alt-H, then it works. I can’t set it back to Alt-H with the keyboard.

don’t have this on windows!

strange then do a bug report for you system
and see what happen !


I’m a little late to the game, but I’m having the same problem. On my laptop it works just fine, but on my workstation, Alt-H does nothing. As far as I know there are no special settings on the workstation. I have a number of other graphics programs on it, but I’ve done nothing special in setting up. Both computers are running XP.

The workstation has XP Professional Version 2002 Service Pack 3
The laptop has XP Home Edition Version 2002 Service Pack 2.

In doing a little testing, I notice that on the workstation Alt-H does not work in Windows Media Player either. Puzzling.

No idea what could prevent ALT+H to work on your system, but a possible workaround would be to change the ALT+H shortcut to something else.

To do so, go to File -> User Preferences -> Input panel

On the search bar of the top right of the Input panel, type the word :


You should then see listed the functions using ALT+H

Click on their “ALT+H” button and press your own shortcuts, the difficulty is to find a shortcut that Blender does not use, SHIFT+Q does not seem used by example

Once done click on Save User Setting if you want Blender to save the shortcut change for everytime you’ll launch Blender after that

All of my edits and changes that I do in edit mode don’t show up when I tab over to object mode. Think this is related? Un-hiding it doesn’t seem to be it but who knows…my edits show up to a certain point, but stop at some point during development and now they only show up in edit mode. Might I have changed some setting on accident at some point? Only started using this recently…the elements that DO show up in object mode have a green line around them when selected and blender lags slightly after i try and move the object like its loading something…didn’t used to do that…I just need help finding out what I could have possibly turned on (or off?). Any ideas? I can only export whats in object mode…and i cant open blender up twice and copy it over because they use separate buffers.

the green line could be you have it grouped OR you have set it to be an active object
would think active if its causing lag (goto T panel ~ rigid body tools ~ remove (with the object selected)

to remove from a group click ctrl+alt+G

Hi, my reply is probably quite late but I hope it can help other people who is having the same issues until now.
In my laptop I have been using a Sticky note background app and it uses ALT+H as one of its hotkeys, once I disabled that app’s hotkeys my ALT+H in Blender works fine to un-hide the vertices.



damn! i would have never figured that out thanks dude!

That was Simple Sticky Notes in the background, THANKS A LOT!! ALT + H and ALT + G did not work in any aplication I tried.

I registered just to say thank you!!

Wow… thanks man. It was driving me crazy. Although Alt+S would bring up the sticky notes and I was wondering why is this shit coming on every time. But still, I would have never known it was interfering with Blender. I deleted the damn thing.

My Case Was Different
I got a New Workstation, and the Alt-H was not working, the reason was “Keyboard Language!”
When set to ENG INTL (United State International Keyboard) the Alt-H didn’t Work, but when Using ENG US it work fine.