ALT+M hotkey bug?

This combination invokes dialog box with vertices merging options. Sometimes due to some unknown reason I cannot bring that box again, no matter how often do I press ALT+M. Thus, I cannot merge vertices with hotkey no more unless I restart the application.

I use blender for Windows since 2.43 version and that problem as far I remember was in previous versions too. This is not critical issue, but sometimes annoying, especially when this hotkey stops working almost right away after Blender restarts. By the way, other hotkeys work perfectly when this problem occures.

The main problem is that I cannot repeat it. I just don’t know what actions sequence makes this hotkey stop working. I can open this action from menu, but this happens to be slow in times when I need to merge many vertices in a row. I’ve noticed some strange things about that:

  1. It happens more often when I minimize/maximize blender window and switch somewhere else. But still, it happens when blender window doesn’t lose focus.
  2. Winamp sometimes goes to tray when I minimize Blender. I cannot explain that behaviour, maybe some kind of weird key combination still on, but I can surely tell, that when Winamp goes to tray, I will never see that hotkey working again in about 70% times.

I’m posting this here with purpose to find someone that has the same problem and maybe to get know a bit more, maybe collect more information for bug report, I dunno. :rolleyes:

W+5 is what I always use to merge. Possibly the ALT+M is just a left over that wasn’t removed. Try W+5 and see if it works 100% for you.

2.45 here.

You press W, which opens mesh tools general menu.
Then you press 5, which opens vertex merge submenu. This’s too complex combination.
Pressing ALT+M opens vertex merge submenu at once, all I need is select merging mode.
W+5 - 3 combinations, ALT+M - only two.
By the way, in front of menu item from MESH>VERTICES>MERGE in edit mode there’s ALT M hotkey reference. I don’t think this looks like leftover, as it really saves time.

As far as I can see it
W, 5 = Two key presses.
Alt, M = Two key presses.

I fail to see the efficiency difference between these two methods. Especially after you’ve done it once… each successive usage would be W+left-click, since Merge will automatically be highlighted.

Regardless, Alt+M is my preferred method, and I’ve never once had any problem with it failing to register. Strange. I wonder if that might be a key combination that Windows is capturing as one of its own hotkeys? I wish I could be of more assistance.

Well yes, it has two clicks in case if I don’t use anything else from that submenu (but I use W frequently for [remove doubles] and [subdivide], as I don’t remember direct hotkeys for them) but only mergeing.)
And that’s not the only problem with key capturing. Sometimes happens that Blender starts to think, that SHIFT or CTRL buttons are still down, when I’ve unpressed them. This makes workflow and all hotkeys act wrong a bit unless I understand that there’s that nasty problem again and have to hit SHIFT or CTRL once more to let Blender know about their actual state :confused:

This sounds like
a) you have a broken keyboard (keys are stuck)
b) you accidently activated some sort of accessibility feature. In windows when you hold the shift key a while windows offers to go into a special mode where pressing shift or alt or ctrl will be left activated until you press the button again. This is for handicapped people. I tend to deactivate it in the system settings.

I’m pretty experienced Windows user (over 8 years of everyday 8-10 hours practice). I don’t think something like that could happen on my machine.
I guess that shift thing is caused by undispatched key message. When blender window loses focus with pressed down Shift/alt/ctrl, sometimes it does not receive release key code and when blender window goes back to front, shift is still down according to it’s trigger system (I don’t know, haven’t ever read src code, just some assumptions) and updates state only when I press key again. In all my applications where I hardcoded key reading system I updated key state variables each time Form gets control back/changes it’s state. Thus there were no problems when user suddenly loses Form with some of keys pressed. I guess, this is somehow related to bug I’ve experienced. This is not so significant at all, my bad that I cannot change Blender focus without some keys pressed down.

Yet another vote for whatever is happening is because Windows is thinking that Alt M has been reserved for another program’s hotkey use, thus making it unavailable for blender…

Winamp has hotkey for minimizing it’s window - ALT+M. I wonder how this could be related.

Given that, I’d say its 100% related… you hit Alt M and windows doesnt know if you mean Blender or WInamp… or maybe even some other program that might happen to use Alt-M as a hotkey.

I’d expect there should be a setting somewhere that you can use to tell windows to only interpret hotkeys in terms of the active program window somewhere…

Windows key thing works other way. There’re messages that are for entire system and are messages (such as key messages) that are for currently active control (Window, panel, etc.). When you’re pressing key in active window, it receives message with action code and some parameters, decrypting which you can get some additional information about action area, buttons, states, etc. ALT+M shortcut (other keys too) works ONLY when Blender window is active and ALT+M shortcut in Winamp works ONLY when Winamp is active. Hotkeys are related and act only depending on active Windows control, whether this’s some application running or explorer, not for entire set.
This maybe related when Winamp is still in focus (“stays on top” window style) and reads key events. Pressing ALT+M changes focus between windows and Blender gets that key combination somehow sticked in it’s own triggers or something else. I guess this’s not Windows problem but related to way how Blender key reading works. I guess I need to look for source code, I cannot tell anything without knowing how it works. Anyway, I tried to repeat that bug in Blender playing with Winamp on foreground and pressing that combination again and again. Nothing happened, shortcut works nicely and then suddenly stops to work for no particular reason or any relation to Winamp.

12 years later this solved half an hour of annoying confusion, thanks!