|Ambient Occlusion and transparency|

Hey guys,

Me again-

Well the topic of my post today is incorporating ambient occlusion maps into models e.t.c
When i model somthing for a game (GLSL or whatever its called :smiley:) and i want to add some AO maps, i normally bake the AO map, then add it as an image along side the other ones (Colour and Normal) and then attempt to blend it in using the colour slider… but that always gives the object a grey look.

Wanting to not have that, im trying to make my AO maps alpha channeled for transparency.
I Kiiindda worked out how to do this but not quite.
Im using blender 2.49b and Adobe Photoshop CS3

So- i bake the AO map with Normalized ticked, so it turnes out like this

http://img17.imageshack.us/img17/3444/43513526.jpg

and applied to the model
http://img26.imageshack.us/img26/264/aoss.jpg

– Now, in photoshopp-
I copy the image into the alpha channel- which

looks like this when applied with alpha, colour, ztransp, A slider to 0.0

http://img709.imageshack.us/img709/1879/aoss2.jpg

No good.

So i tried inverting the image, ok result
http://img22.imageshack.us/img22/6324/aoss3.jpg

But-- if i add another image or texture, the alpha channel applies for the whole object.
How do i get it so the alpha channel just subtracts the white, and leaves the shadows. and is layered over the other textures, and maybe underneath the normal map= and WHY does AO Baking in blender does this for you!!! Like bake AO as transparent NOT with grey!!!

Can anyone give any suggestions?

Hi,

I might not understand what you want to achieve, but if you want the AO texture to affect the lighting of another texture, you should change the mix mode of the AO texture to Multiply the next texture. Alpha affects the transparency of the object, not how much of the texture shows through. If you use Multiply, the white bits of the AO texture will show the next texture at full strength, while darker bits will make the next texture darker.

Hey rawpiegeon:
Thats kind of what i’m looking for. I want the shadows and spots/noise of the AO bake to show up, just not the plain white or grey you get with the bake.

along the line of

http://wiki.flightgear.org/index.php/Howto:Add_smooth(%22Ambient_Occlusion%22)_shadows_in_Blender

Hi,

I have a similar problem, i think. I’m quite new to blender.
I am animating several objects that overlay each other. I want to fade some in, so I’m using alpha.
I will try to explain this as clearly as possible,

The top object, i want it to fade in while the bottom object stays in place and does not change at all. When I animate the alpha of the top object to fade in, at alpha=0 instead of seeing the bottom object behind (as if the top object is just transparent) it shows the background of my world (sky and ambient occlusion). I want to just see the bottom object.

I tried changing from mix to multiply on the Ambient Occlusion panel in the worl settings but it would not allow my to change to any of those options, including multiply.

Any suggestions?? Your help would be much appreciated.
Thanks,
Leah

Hi,

Have you got ZTransp enabled in your material settings?

ZTransp! Why, no, I did not have that enabled. It is now and works a treat! Thanks rawpigeon!!!
So much to learn,
L