Ambient Occlusion is not baking where it's supposed to

I’m doing a tutorial here: There are parts of the mesh that are not supposed to have ambient occlusion because they are rubber or are getting a separate texture later on. I move the mesh that’s not supposed to get A.O. out of the UV square. I bake. Then when I go into cycles and in the texture node add the saved png AO image, my Robot has parts that are not black. It changes each of the several times I’ve gone through the process. Can someone tell me how I can get the robot rubber gaskets, eye balls, light lens and cylinders to come out black like it shows in the tutorial. (showing that there is no AO on those parts)?

Screen Shots:
Shows the parts I don’t want to have AO:

Just before baking:

In Cycles texture mode using the PNG AO in the texture node:

Blend file:

Add a Mapping node with Min and Max enabled so the texture does not get tiled

Thanks. I didn’t get the email I always get when I get a response from this forum. I did the AO first and then the Normals. Eventurally I got something I could work with. It still was not right. But I went ahead with the tutorial anyway. I was planning on deleting affected Robot parts and duplicating the opposite side to replace them. That was my plan anyway. (Probably mess things up good.) I added the two nodes above, and I don’t see any problems now. Thanks again!