Ambient occlusion node is canceling the render viewport in 2.83 cycles?

Hi everyone,

Hope you can help me with this one.
I try to use the AO node for shader blending purposes, but as soon as I add the AO node the viewport doesn’t want to render anymore and everything stays grey. Even when I delete the node the viewport still doesn’t render. Am I doing something wrong? It looks like something breaks under the hood when I add the node.
I also tried to enable ambient occlusion in the world settings tab but that doesn’t do anything either.

Thanks in advance.

Is there a specific reason why you use 2.83?

Yeah, unfortunatly I have to. I checked in 2.93 and there everything works fine.

Documentation just says that if distance is too large, objects are considered as infinitely large and AO is overshadowing everything.

You said that you are using AO as a factor for blending purposes and you enabled AO in world settings.
So, destroying the node may not change the fact that blending is still incorrect or AO from world settings could be the cause of everything staying grey.

Thanks for the reply.

Unfortunately it also happens when I don’t turn on AO in the world settings… So I think it doesn’t have to do with any of that.

I just tried this:

  • If I turn on rendered view without the AO enabled in the world settings or add the AO node, everything is fine.
  • If I turn on the AO in the world settings, everything just gets brighter but the scene still works.
  • If I also add the AO node to the material, the render view just freezes. The only way to fix it is to delete the node, close the scene, and open it again. Then the rendered view works again.

Very strange…

AO was redone in 2.93.
That is possible, that early version of EEVEE in 2.83 was not able to handle AO for your hardware.

Maybe it works for a F12 render.
If it works, you can try to avoid rendered view, keep solid shading for viewport and try to set-up AO through F12 render tests.

1 Like

I got it!
Apparently I had to turn off OptiX. My Viewport Denoising OptiX AI-Accelerated was still on.
I figured it out because when I rendered with F12 it told me OptiX wasn’t compatible with it.
It even works in rendered view now. Thank you!