amd r9 290 ,no gpu in ubuntu 14.04 with the official driver 14.5 or 15.1

I installed the latest two version of the official driver 14.5&15.1. in the blender2.75 ,no gpu . What should I do?

AMD r9 290 &ubuntu 14.04 64bit

How you have installed the driver? If you have installed it from repositories, in another thread someone said that you need to have the “fglrx-dev” package installed to.

0: sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases libqtgui4 debhelper debconf libstdc++6 dkms libqtgui4 libelfg0 linux-headers-generic

1: sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*
2: sudo reboot

3: sudo dpkg -i /path/fglrx-core_14.501-0ubuntu1_amd64_UB_14.01.deb
4: sudo dpkg -i /path/fglrx_14.501-0ubuntu1_amd64_UB_14.01.deb
5: sudo dpkg -i /path/fglrx-amdcccle_14.501-0ubuntu1_amd64_UB_14.01.deb
6: sudo dpkg -i /path/fglrx-dev_14.501-0ubuntu1_amd64_UB_14.01.deb

7: sudo aticonfig --initial
8: sudo reboot

Did I do that right?

And what happened after reboot?
I clarify that I do not have an ATI card.
Maybe that you did is fine as long as you have not copied and pasted from some tutorial things without really knowing what you were doing. Have you properly chosen that path pointing to these .deb packages?

You verify if you have these packages installed correctly with:

sudo dpkg -l | grep 14.501

Driver installation should be no problem, the test is ok. Before need to implement CYCLES_OPENCL_TEST=all. But now it’s not working.

ii fglrx 2:14.501-0ubuntu1 amd64 Video driver for the AMD graphics accelerators
ii fglrx-amdcccle 2:14.501-0ubuntu1 amd64 Catalyst Control Center for the AMD graphics accelerators
ii fglrx-core 2:14.501-0ubuntu1 amd64 Minimal video driver for the AMD graphics accelerators
ii fglrx-dev 2:14.501-0ubuntu1 amd64 Video driver for the AMD graphics accelerators (devel files)

thx you,but nothing changed:(

Hey, it looks like the driver you have installed is not the latest driver (even people are recommending beta driver). Send a private message to “@manulato” and ask which version of the driver you need in Ubuntu.

This is how netzhang79 has solved the problem:

Thanks for sharing!

thanks a lot!

Hi guys! I had same problem and i solved it by just installing a few packages: ocl-icd-libopencl1 and ocl-icd-opencl-dev. I hope its will helps you too.
sorry for eng