AMD's (ProRender) Plugin for Blender Previewed


(bsavery) #321

Sorry about that. Marketing was big on stressing macOS ;). Windows and Linux are updated as well.


(bsavery) #322

That is partly the intention of how the volume shader is meant to work… though I haven’t tried it myself, so I’ll give it a go when I get the chance.


(Metin Seven) #323

It’s looking good, renders fast, and works intuitively, especially if you’re used to working with other GI renderers such as Cycles. Thanks a lot for providing AMD ProRender for free, much appreciated.

A minor remark regarding the MacOS version: during installation it’s slightly confusing if just pointing to the Applications folder is sufficient, or choosing Blender’s own subfolder inside Applications is needed. I first chose the Applications folder, because that’s the default folder the installer points to, and Blender used to be installed in there. But since a few versions, Blender installs in its own subfolder. Maybe a check for that folder could be included in the installer.


(Lsscpp) #324

Hi bsavery, I have one question: why on Earth is ProRender installation filesize > 500Mb? How can it be? Is it something AMD can work on? I see Cycles, LuxRender (the new one) are about a few Mb, providing the same (or more) features.

edit: shame on me! i saw that it is the material library that takes up to more than 600mb, while the renderer itself is around 66mb on windows


#325

Yes.

^That’s the Material Library ~ 616 MB (unpacked). Plugin alone takes ~ 67.4 MB (unpacked). IIRC, in future, they’ll be separated.


(bsavery) #326

Yes, that’s the plan.


(ajm) #327

Is there any reason why RPR would install itself as root on Linux and not let Blender see it? I followed the install instructions on the site. None of the file permissions let me use it, and the install kicks out RenderMan and LuxCore plugins. Was going to give RPR another try, but, damn, it just doesn’t seem destined to be for me. I want to use it, but apparently the Universe has decided otherwise.


(bsavery) #328

Kicks out other plugins? Woah that seems weird. I haven’t tried the linux installer in a bit but I’ll forward this on.


(bsavery) #329

Did you run the installer as sudo or su to root? There is an remove operation in the installer but it just removes the old ProRender directory


#330

Win7, Blender 2.79b (gtx 1060, q M5000)
Short late test and experience:

  1. Rendered image gets overblown as soon as it gets affected by the compositor.

  2. Texture Compression enabled without textures in the scene takes quite a long time and then throws an error.
    https://i.imgur.com/0C2RpD8.jpg

  3. Denoisers only work in ‘Render Preview’.
    In fact, data seems to be processed as it takes more time to finalize the render but results stay unchanged.

  4. IES files are oriented in Y direction (rotate 90° on Y to show properly)

  5. With Denoiser activated, Material Preview stops responding (stays black).

  6. With Material preview open Render Preview continues to restart after approximately every 1~2 sec…

  7. ‘Device Type’ set to CPU, starting ‘Render Preview’ returns with an error:
    https://i.imgur.com/QrHTSPZ.jpg

am tired now… maybe later :spin:

Edit: With an older scene different, better results, terminator gone, denoisers working… more tests needed. :rolleyes::wink:


(Metin Seven) #331

Hi Brian,

A few more things:

• When I check the CPU checkbox on my Mac to activate CPU + GPU, Blender crashes.

• The state of the CPU checkbox is not saved along with a scene, but seems to be a global switch during a Blender session.

• Is there already a material node to support Blender’s vertex color channels? I’m using vertex colors a lot for painting surfaces, and it’s also very important if you want to render models imported from ZBrush (with Polypaint converted to Blender vertex colors).

Thanks,

Metin


(ajm) #332

@bsavery

“Did you run the installer as sudo or su to root? There is an remove operation in the installer but it just removes the old ProRender directory”

The instructions on the site said to do sudo, I don’t like being in su if I can help it. It said that it could also be run from the GUI by making the file executable, but it fails. When I installed it, Blender said RenderMan and LuxCore was missing so I reinstalled those addons, but it couldn’t find RPR either though it was listed as a addon like the others, just missing (more than likely Blender didn’t have permission to access it outside of root). Every folder RPR installed was installed as root, thus every file as well. I think my only way around it from a usability standpoint would’ve been to run Blender as root, but that’s not going to happen. It didn’t do this with RPR 1.5, but then again, I couldn’t use RPR on my Ryzen either, both in Linux and Win 10.


(ajm) #333

So made some changes and got it to install…kind of but now get this.



(glmr) #334

new bug



(glmr) #335

I found a bug.


there are black triangles on some objects. it doesn’t depend of file format - I tried obj, fbx, 3ds etc. the issue appears also on transparent objects when a texture applied.
appears only with GPU render. CPU works fine


(serviteur) #336

Hi,

I need to install RADEON PRORENDER1.6 on Xubuntu16.04.3

Radeon ProRender for Ubuntu

  1. Download and install the amdgpu or amdgpu-pro driver and include OpenCLTM.
    Show help options: ./amdgpu-install -h
    There should be an option for --opencl that needs to be used.
    For example: ./amdgpu-install -y --opencl=legacy,rocm
  2. If the non-pro driver was installed then run the following:
    sudo apt install libgl1-amdgpu-mesa-dev
    sudo ldconfig
    The pro driver already executes this and the sudo ldconfig command is required.

I have problem with some command:

serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ ./amdgpu-install -h
bash: ./amdgpu-install: Aucun fichier ou dossier de ce type

No file or folder of this type

serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ ./amdgpu-install -y --opencl=legacy
bash: ./amdgpu-install: Aucun fichier ou dossier de ce type

No file or folder of this type

serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ sudo apt install libgl1-amdgpu-mesa-dev
[sudo] Mot de passe de serviteur : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libgl1-amdgpu-mesa-dev

Can not find the package


serviteur @ HP-EliteBook-8760w  ~
└─ $ ▶ 





(BeerBaron) #337

The problem is that you don’t know how to use the Linux commandline at all, so you fail to recognize when documentation is missing out some steps. I strongly recommend you learn more on this topic, if you plan to use Linux.

“./amdgpu-install” means:
Look for the executable file ‘amdgpu-install’ in the current working directory (i.e. ‘./’) and run it.

You are still in your home directory ‘~’ and you haven’t put that file there (the documentation omits this step), so it can’t work.

Here’s a more detailed explanation of the required steps. You need to download the archive, unpack it to some directory, change to that directory, run the executable from there.

serviteur @ HP-EliteBook-8760w ~
└─ $ :arrow_forward: sudo apt install libgl1-amdgpu-mesa-dev

That package doesn’t seem to exist in Ubuntu/Debian repos, so I assume the previous failed “amdgpu-install” would’ve added a repository that contains it.

I need to install RADEON PRORENDER1.6 on Xubuntu 16.04.3

Do you really need to? Try following the documentation here, if that doesn’t work, just give up. You’ll be wasting time fucking around with things you don’t understand, working with information that is incomplete or that doesn’t apply.

Also, I would avoid using french language for the operating system, because that makes it much harder to google the error messages or asking for help online.

If you just wait a while, those AMD drivers should eventually (hopefully) land in the Linux kernel, then it will just work “out of the box”. At least that’s what happened to the previous generation AMD GPUs.


(thomascheng) #338

I did a quick comparison of ProRender 1.6, Modo 12 and Blender Cycles 2.79b. I think ProRender is the clear winner here.


#339

@glmr
Oh… is that terminator? Could you post a file?

@thomascheng
Really?
Just for starters: Workflow? Time to setup? Specs used. Shaders used. Resources used & their efficiency (CPU ?%, GPU?%, RAM, power consum.) Been so many times through similar showcases which often show only lack of proper comparative study. Some inspiration and examples here: https://www.janwalter.org/download/


(Simon Storl-Schulke) #340

Oh my god this site is a gold mine why didn’t I know about this?!