AMD's (ProRender) Plugin for Blender

So Hybrid Modes now don’t work at all. It spews some python error, then switching back to Full mode causes 2.81a to crash to desktop.

I get the impression that nVidia GPU users are pretty low down on the priority.

I’m wasting my time with ProRender. Uninstalled.

I’m sorry for your experience. We obviously can’t test every example of our competitor’s cards. However on any of the 20X0 series (and 1080) with recent drivers and Up to date windows we’ve gotten good results. As have many users. The main issues we’ve seen was out of days windows version. Anyway we’re trying to make this work for everyone but we can’t chase everything and if our competitor breaks something in drivers it makes it harder.

Anyway sorry again.

What version do you consider up to date? I’m on 1903

edit: updated to 1909!

1909 is the current Windows 10 version.

Wasn’t 1903 1st quarter of 2019 maybe last quarter of 2018?

Edit: Looks like 1903 was May 2019, with 1909 releasing in November 2019

1 Like

The insinuation being that I’m not running up to date Windows or Drivers, okay, I’m using 1909 and nVidia Studio driver 442.19 on dual 1080TIs.

I have no problem running any other GPU renderer on this system in Blender or C4D only ProRender2.0.

Surely the whole point of ProRender is to get people like me who want to ditch nVidia at the earliest opportunity all the ammunition to make that move. In this borked state ProRender says to me I’m better off with the devil I know.

So I uninstalled Blender 2.81a, reinstalled it. Reinstalled My nVidia drivers, rebooted. Reinstalled ProRender 2.3. There’s nothing more I can do my end. This computer works flawlessly with the rest of my software and Cycles.

Same error appear in viewport when I switch to a Hybrid mode. Crash to desktop when I try to switch back to Full Mode.

We actually have a fix for this coming in a day or two. If you want to fix this yourself, it’s 2 lines in a python file:


Just be a little more patient. It is after all a pretty new software.

I for one am actually quite happy to see an alternative to CUDA.

EeVee and cycles is a pretty fantastic combo but ProRender and Vulcan based GI is also quite great to have.

Hybrid mode currently is also broken with AMD cards - or at least my rx 5700 xt.

same bug again -_-
win 10 + last nvidia drivers

Fix works fine, here’s fixed file for anyone interested: (10.9 KB)

But I had few more issues.

First, the latest RPR installer (2.3.1) simply just uninstalled previous version (2.2.12) and didn’t do much more or anything else. Tho RPR got registered as installed, but nowhere to be found. It was after 3rd installation attempt that things fell to their places.

And then…

  • I opened an older scene ready for EEVEE, Cycles & LuxCore. Looking through Camera, while simply trying to rotate around an object and selecting a different one, couple of things happened:
    – the selected object in focus started to move with Camera while zooming… as if it was parented.
    – while selecting different objects NANs showed up until “refreshed by a camera move” (as can be observed on a previous post above)

New Camera object fixed both issues.

After, it worked like a breeze – smooth and quite fast.
using CPU (AMD TR 1950X) or GPU (NVidia GTX 1070)

Also, isn’t Y axis the North, thus Sun&Sky system azimuth needs a correction of +90°…

The azimuth angle indicates the direction of the sun in the horizontal plain from a given location. North is defined to have an azimuth of 0 ° and south has an azimuth of 180°.

Says someone who clearly isn’t using ProRender otherwise they’d have reported this very obvious bug.

I’ve at least had the temerity to use ProRender 2.0 since its release and I have reported bugs numerous times, so have others too but these reports have been ignored as these same bugs have not been fixed. The get out of jail card has been ‘it’s your drivers’ yet we’re never told which drivers the release was tested against.

Clearly this latest show stopping bug had nothing to do with drivers even though that was the first reason offered again. I don’t know what the ‘many users’ have been using?

Personally, I’ve had enough of the abusive relationship from nVidia and I’m craving AMD options but that would paint me into a very small corner of OpenCL Cycles without ProRender being a production ready renderer. So far ProRender 2.0 an interesting tech demo but I want something dependable that I can use in production. Then when the powerful Navi GPUs are released I’ll happily fill my workstation with them.

1 Like

Reading the AMD ProRender forum these black squares are caused by Adaptive Sampling being on.

I actually did test it a lot - and still use Cycles.
As said be more patient this is a new software.
Call it a tech demo if you want which is however a bit to condescending.

If this is production ready - feature complete? Depends on what you need.

Also maybe don’t shoot the messenger instantly. Bsavery also quite quickly later stated that they found the issue while his first initial idea was driver related.

1 Like

So you’ve found a new thread to dump your ignorance on. For once do yourself a favour and mind your own business and don’t presume to tell others how to respond.

I rather doubt you done any level of testing of ProRender much less tried to use it in a professional production, I don’t see one single example of you reporting bugs. If you had you would know that the Hybrid Modes are the quickest way back to the Desktop, they are so unstable it’s actually charitable to call them a tech demo. The software is being released as a ‘stable’ build and therefore a user should expect a certain level of polish not crashageddon. If this was still a beta I’d be much more understanding.

Within 30 seconds after installing this latest release I discovered the new bug and crash. If I can do it so quickly how was this not discovered by AMD? It makes me wonder just how seriously they’re taking this development. If ProRender 2.0 is really just for AMD GPUs then there should be a bit more honesty regarding the stability on nVidia GPUs then we can stop wasting our time.


Just read your response again and compare to what I wrote.

I test RPR since version 2.0 but it simply is not there yet.

I can be patient since it is a free software without putting on an attitude.



The Blender startup time is increased drastically by this add-on if the pc does not have an active internet connection, because it tries some http connections during the start up. It would be nice if this check time is cut down or even better it does not even try to download libs if no connection is avail. Or just ship the lib with the add-on itself.

Please see the logs

The fact it is free has no bearing on the matter. There’s no warning from AMD that this is ‘early’ software and too expect problems. This is not beta software.

This has been there since 2.0/2.1 for both nvidia and mad cards.

It is a pretty annoying visual glitch.

sir, what about black squares bug? Will it be fixed?
This should be an extremely high priority. Because of this bug, I can’t use RPR at all.

Yes, We’ll put up a new build tomorrow. I posted a fix above.

Be patient. It is a tech demo. The developer just got the numbering wrong. Probably it is version 0.2 and not 2.0.