Angle Tool


I like the tool but it’s really hard to work with it for what I was expecting.

  • You need to have a edge selected with the correct angle. You cant use cursor, a vertex…
  • I can’t work in modal tool like the activetool, only enter manually the value.
  • You can’t use the blender classic snap, it use a custom snap value
  • If you work in modal tool, like I do, the tool is extremely laggy

For those who had that kind of error message :

location: :-1

AttributeError: ‘NoneType’ object has no attribute ‘verts’
edge_verts = [edge.verts[0], edge.verts[1]]
File “C:**\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\”, line 1510, in modal
File “C:\Users\ncote\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\”, line 681, in rotation
Traceback (most recent call last):

You can fix it by disabling the «Auto Merge Vertices» in «Edit Mode»


Holy ****, works!!! thank you very much!!!


Hi Nyko! Thank you very much for reporting a fix for this extremely pesky bug. I will add this in the documentation and try to fix the add-on now that I know what it’s caused by!

Much obliged!
:exploding_head: :heart_eyes_cat:


Great! I’m glad I helped, keep up the good work! :grinning:

1 Like

Another subject I want to bring on, unless somebody already mention it because I didn’t read the whole thread, is about the deformation produced when the scaling of the object is not → X:1 Y:1 Z:1

Example :

Step 1 - A : An object has random scaling
Step 1 - B : Do the Angle Tool at 90°, results unexpected length of transformation
Step 2 - A : To correct that, I revert in the history (just before the Angle Tool command) and I Apply the Scale in Object Mode
Step 2 - B : Expected results

It’s interesting that when the scale is random it deforms at an exponential length, but I guess it’s not what we want after all!

Something similar for Bevels :

Finally man, working with corners is always painfull. And the addon is super simple with for me is a +. Thank you!

Edit: Just saw that the addon is old, and i only found out about it today…

1 Like

Hi z01ks,

I also met this error, there with Blender version (updated this morning).
The addon looks awesome, hope it wont be so hard to fix :slight_smile:


Hi Vojtisek,

Sorry about that. Have you tried turning off Auto Merge? Hope to resolve this bug soon.


Cool, thanks! Yeah I noticed there was an article about it.

Thank you, you were right, Automerge is the devil :). Works great!

1 Like

So i think i might have found a bug, at least on the alpha version of 2.90. After activating the curve mode © i can’t turn it off. It works if i close and open the blender file again.

Could you try pressing A to get back to Angle mode? I think C doesn’t work for toggling Curve mode. I can’t recall why I made this choice…

the operator is still very laggy
when scrubbing any plans for optimization update?


Having a bit of trouble producing a 90 degree curve with equal segments. Always ends up skewed like this:

1 Like

Hoping for that too.

You can try to «Apply Scale» to your object, then your corner should be 90°.

Handy tool, thank you. I started to use it and started to love it :wink:
P.S.: i am using on 2.90 - seems fine, so far.

if object was bugged out with automerge, addon stops working on it completly even if you turn it off (it kinda works but it is extruding inverted faces), i dunno whats causing it and how to fix

Lovely tool! Just had a small hiccup which I wanted to highlight. First of all, works great. However, when I tried using it in a larger scene with near 1 million tris, the tool runs really slow. As soon as I hit the hotkey it takes up to 20 seconds to complete. So it’s a bit unuseable in that environment. Workaround would be making a new scene and edtiing the geometry for an object separately, but anyway, just wanted to let you know.

1 Like