Animated Actions in GameEngine won't work

Hello guys, I have recently started with the game engine of Blender so that I could make a simple game in which the player can control the character. So far I have been able to move the characters using keys, destroying objects when touched and restart scenes etc.
I haven’t tried animating anything until now and suddenly I am having the problem that I can’t play the animations in the game engine. I set up two actions, an idle animation and a walk animation for my character. When I try to play them using a keyboard input it’s not showing any animation. The game isn’t freezing up as I can still move.

I also noticed that I can’t start the game engine when I have an armature selected, so I always have to click an object to get in objectmode and start the engine, is this normal? I am currently using 2.56 Beta.

I have attached a .blend file so you can look at it.


Danbo_GameEng_2011_03_21.blend (887 KB)

I’m no pro at this yet, but have you tried using F-curve actuators to trigger keyframed animations instead of using actions?

Go into your object settings for the model and look at “relationships”. go to parents (it should be set to your armature) and select the type from “object” to “armature”. What should happen is that it f*s up. This means it’s working. Now go into your modifier tab and delete the armature modifier.
It should go back to normal.

Let me know if it works :wink:

If not you have the same issue as me…

As LubeyRin said you should be able to delete the armature modifier and it should work. But one thing he forgot was to set the parenting type to armature.
heres 3 tutorials from the cookie that should help

Actually, I had already done that as I was using that tutorial for animations. Removing the modifier and setting a parent relation didn’t help.

I have tried that solution, it works but I didn’t have any other modifiers attached so that wasn’t the cause of the bug.

I have removed the parent relation and gave it a new armature modifier. After doing this I also noticed the movements for the head and leg weren’t playing. After I fixed this I tried to remove the armature modifier again and parent it as an armature, but the animations didn’t play in the game engine. With the modifier it does work, but I don’t know if any bugs will occur using the normal way of adding the armature.