Animated Render Border add-on

Hello All, I’ve just released an add-on called ‘Animated Render Border’, for sale on the Blender Market, available here.

I thought I would create his thread to serve as a focal point if anyone had any questions, comments or suggestions (and of course, to publicise the add-on a bit).

The main purpose of this add-on is to allow the border render feature of blender to be able to update it location and size every frame to always encompass the selected object or group (mesh objects only for the minute). This can be useful when wanting to render an animated object at final quality, but not render any of the surrounding areas, so as to preview it or to skip rendering transparent areas of the image (which can happen if an object is on it’s own render layer).

Key Features:

  • Animates the render border to always surround the selected objects or collections of objects during an animation.
  • Allows manually keyframing the render border for precise animation.
  • Adjustable ‘margin’ property to give ‘padding’ around tracked objects.
  • Track objects using precise tracking or a faster, but less precise bounding box tracking mode.

Here’s a (choppy) GIF to show it in action:

On a day to day basis, as I’m not always rendering animations, I’ve also just found it useful to be able to select the object I want the border to surround from a drop-down box instead of having to draw (and, inevitably re-draw) the border in the viewport, but that’s a rather minor benefit.

I have made a short demo video below, which goes over what I’ve just said and shows all the available options, like margins around objects and different methods to track the objects:

Feel free to let me know what you think (as if I could stop you :wink:) below.



Latest release notes:


  • Updated add-on to work with Blender 2.80.
  • Removed the ability to render when an image format is selected in the Output panel (this was a mistake and resulted in multiple video files being created instead of a single output file).
  • Various UI fixes related to tracking bones.

This is great! I’ve needed this for almost all my motion graphics projects, once I get paid I’ll be able to buy your addon.

Thank you very much :smiley:

Thanks. Be sure to let me know if you run into any problems or have any ideas for improvements or new features.


I recently bought your “Animated Render Border” add-on for Blender 2.79, but now I’m using Blender 2.8, and I can’t use the add-on. How can I use it on 2.8?

I bought recently, less than a month.

Thanks in Advance.


You should have got an email from the Blender Market about the 2.80 release of the add-on I did last week. If not, you can download the updated product from the ‘Orders’ page of Blender Market.

And, not that it particularly matters as I don’t mind using Blender Artists for support, you can get support for products you have bought by clicking the ‘Create Message’ button on the product page. (More information here:

Hope that helps,


1 Like

Hi Ray, I had not done the registration on Blender Market. But I did it now.
And I just downloaded it.

Thanks a lot !

Hi Ray, how are you?
I need your help again. I’m using “Animated Render Border” add-on in Blender 2.8 to improve my render time.
I’m tracking only one object, making a 360 grades lap, but in some frames the object was cutted off in corners.

I’m using 7 to Margin. But anyway its happen. How can I solve this problem? Can you help me?


Sorry to hear you’re having issues.

I don’t know what “360 grades lap” means, but to solve the problem I will have to see the blend file. If you can create a simplified version of your file which still shows the issue I will happily take a look at it.

Should you want to email this file, my address is at the bottom of the user guide that came with the add-on, or you can use the ‘Create Message’ button the product page on Blender Market or you can just drag the file into the reply box on this page.



Hi Ray,
Sorry for my English =D.
I meant, 360 degree turns.
I will send my example where this occurs here.
When I put to render all frames. Some frames get cut off. This occurs in frames 1 and 2 for examplePacote Grande de Fraldas - Example.blend (775.6 KB) .

Hi Gabriel,

I’m afraid I can’t currently recreate the issue with the file you have provided. Are you sure this file is the one demonstrating the issue? In the previous message you said you were using a margin of 7 and in this file the margin has 0. If I open the file and don’t do anything I should be able to render and see the problem?

Is the tracking happening correctly in the viewport and it’s only in the render that it isn’t working or is the viewport tracking off too?

Are you using the official release of 2.8? I only had issues of objects being cut off in very early versions of 2.8, well before the official release. I also tried in 2.81 and didn’t have the issue.

If you’re on Windows, if you go to Window> Toggle System Console, can you see any errors there?


Thank you for developing this amazing add-on.
I found a problem while testing and write a report here.

  • I set the frame step value to 3 and rendered through the Animated Render Border. This works correctly in the GUI.
  • Problem occurs on the Command Line.
    I can perform rendering via --python-expr" import bpy; bpy.ops.render.animated_render_border_render () ", but Animated Render Border will render all frames, ignoring the frame step 3 stored in the blend file. .
  • I tried -j 3 and --python-expr "import bpy; bpy.context.scene.frame_step = 3; bpy.ops.render.animated_render_border_render () but still Animated Render Border renders all frames It is.

Q: Can I work with Animated Render Border and frame steps on the Command Line?


Sorry you’ve had a problem with the add-on. You’ve discovered a fairly obvious bug, which I should have seen. Thank you for your detailed steps on what you tried!

Unfortunately, to get the render border to work I have to use my own render button, which also means there are a few features I have to implement myself (which is also why the -j argument was ignored).

Fortunately, the fix is very simple. You can either change line 420 of the script from

for i in range(oldStart, oldEnd+1):


for i in range(oldStart, oldEnd+1, context.scene.frame_step):

and reinstall the .py. file or you can wait until the fix is live on the Blender Market (I don’t know when this will be as I tend to only update it when there are more than a few fixes in the update).



1 Like

I am sorry for being late. I’m back.
After modifying line 420 according to your instructions, Animated Render Border now considers the frame step on the command line!

In other words, Animated Render Border can now be used when managing the rendering of multiple blend files from the command line in a stop motion or non full frame style animation project.

Thank you for modifying the code.

Meanwhile I found a useful suspended project that can remove duplicates from Blender rendering along with the Animated Render Border.
I have no intention of letting you do something you do not want.
But if you are interested in this, you will be able to develop.

Do you know Dopplerender?

Think of stop-motion or non-full-frame animation. Basically, the animation proceeds as twos, but ones or threes are used partially where you want to emphasize.
In this case it can be difficult to manage with Blender’s default frame step.
If you turn off the frame step and render it, it will render as the animator intended, but it takes more time because it renders twice for the hold keyframe section twice.
Also, consider sitting and standing up.
Standing up can be just reversed same frames of sitting.
There are so many duplicates, and Dopplerender renders the same image only once, and the rest is said to complete the image sequence by copying the image.

I think if Animated Render Border and Dopplerender work together, duplicate rendering could be reduced even more than now.
Unfortunately the project seems to have stopped and I am not a programmer so I can’t use the code.

The link in the first post leads to:

Shouldn’t it point to ?

Thanks. The old links used to work but they seem to have stopped redirecting now for some reason. I’ve updated it now.

No problem, thanks for reporting the bug.

Sorry, for the moment I prefer to keep the add-on focused on its very specific task of moving the render border.



Right, it’s good to focus.
Thank you for continuing the wonderful work.

Hi Ray.
When I modified line 420, I found an additional problem and report it here.
The info editor prints a message that there is a problem with line 872.
This doesn’t have any problem in terms of rendering, but it seems to be inconvenient to read the information in the info editor because it outputs an error message each time the cube is clicked or an item in the outliner is clicked.


Thanks for reporting the issue. You added ‘(modified)’ to the add-on file name, which I believe is the cause of the issue. If you rename the add-on file back to ‘’ the issue should go away.

The method I use for accessing the add-on preferences is dependant on the name of the file - I didn’t know there was another way when I first made the add-on. I have fixed this now.



Hi Ray,

I just bought the addon.

Is there any way to stop the render once it’s started? (imagine you see a problem and want to stop to tweak befre re-rendering).

… thanks!