Animated Textures not working?

Just a reminder, I am trying to get this to work in realtime (P key), not rendered animation.

I have done a lot of animated textures in the past (Blender 2.36~37), and I was pretty sure I remembered it correctly: just use a tiled image, uv-map to the first square of animation, press N in UVWindow, activate both Tiled an Anim buttons, enter number of tiles and number of animation frames.

I recently installed the new Blender 2.42a, and I simply can’t get any textures to animate at all. For any object. From a single face plane to a complex object. From JPG to PNG to BMP. I do all the above and when I press P the object just displays the texture as it is adjusted in the UV Window (just the boundaries correct, no tiling and no animation either).

Funny thing is, whenever I try opening an old file with animated textures and press P, all textures animate beautifully. But if I try creating a new object in the very same scene it won`t animate the textures… Also if I try to use the same PNG I was having trouble animating on the other scene, it DOES animate in the working (old file) texture-animated object.

Is there a bug in current Blender? Or am I forgetting to do something?

PLEASE reply, I`ve been up all night trying to figure it out!!


:frowning: :eek: :eek: :wink: :frowning:

Yes, I guess that animated textures function is broken!! :frowning:

I think they work it you have Blender materials turned off. They did in an earlier version, anyway.

I’ve use DocHoliday’s TileTex 5in1 file and it works nicely.

get it here

late :cool:


I didn’t know it was possible to use Materials in the Game Engine, must be something new? Anyway, what exactly is it? Would it be like enabling specular, opacity, bump maps etc (as if making a 3DS Max Material) and applying this to a game object? Also, how do I enable/disable it? And do I have to use Materials for EVERYTHING in the game if I enable it, or just where I find it useful?


I got the tools, but still havent used them. What are they for? The site is in German (seems so) and I dont understand it…

If you go in the game menu at the top of the screen, there’s a choice for “use Blender materials” and it will have a check mark next to it by default. I personally prefer to use them, but a lot of people don’t. If it was me, I would try doc’s script for animated textures because it works even with Blender materials turned on.

There is a parrallax script that enables bump/normal mapping in the game engine. I don’t pretend to understand how it works, but if you download the demos for 2.42 you can see it(as well as a ton of other new features) in action.

The demos files can be found here

The engine_graphics_demo has the parallax file.

AFAIK, you have to have materials set for every object if you have ‘Use Blender Materials’ enabled. It does make for a bit more work, but the results are worth it.

no you dont have to have materials on every object if the object has a material on it it will use it if it has No material AT ALL it wont it will use the regular uv texture

gamekillbr - If you go to and click on language tools, you can translate the the site from german to english.

I’ve used the TileTex 5in1 to get animated textures to work with blender materials turned on.

I made these tiles with the gimp, from a LOTR preview using the layergrid script.

Wow thanks for the replies guys!!! These Blender Materials look really useful, I’m gonna try to study this matter. As for using the 5 in 1 scripts, if it does work with Materials turned on, gues that’s the best solution all around…

:smiley: :wink: :slight_smile: :wink: :smiley: