Animating material opaque to transparent

I’m using blender 2.74 and I want to make a few solids parented together, to change color form opaque to transparent.

Basically, when using Blender Render, I only see results in Preview window. Unless I switch to Render shading. Material, or any other, shading mode does not reflect the effect of materials Alpha animation.

However, I have this other project, and there’s no problem with viewing material Alpha animation even in solid view port shading. Why is that?

I’ve tried opening a new project and different settings and nothing gives me the right (or any) result.

When working in cycles I have same results. One solid is behaving as I want, while the other does not even show the material color in solid mode, not to mention any Alpha animation.

So you’re not actually going to supply the file that works and the file that doesn’t work so we can see what the difference is ??

Sorry about that. Here’s the file. I’ve done it on cycles at the moment, and it works. Buty only with main solid.

https://drive.google.com/file/d/0B4-ahYG_rjp4OUVFcmN0TWJzNEE/view?usp=sharing

Also, I’ve rendered the animation and material change is not visible.