Animating materials & the 'Traceable' option.

Hi, i’m trying to animate material properties with the ‘mode’ ipo channel, when i insert a mode ipo key, the traceable option turns off by itself on playback… can’t find a workaround or solution, is this a bug or just me being a noob?

For Mode IPO’s Traceable is on Y-1, the chanel above zero. It’s on for the frames where there’s an IPO Curve and off where the curve ends. To end the curve (front and back) you need to key something other than Traceable (Shadow [chanel2], Shadeless [chanel3] etc).

http://uploader.polorix.net//files/111/Mode.blend

That example has Shadeless from frame 1 to 20, Traceable to frame 40 and back to Shadeless.

%<

Mmmm, still not getting it… how exactly do i reproduce your example?? I tried inserting mode ipo’s with all kinds of settings but still no curve at Y-1…