Animating MetaObjects with armatures?

I’ve tried all the suggestions I’ve been able to find to attach a metaball to an object so I can animate it. Can’t seem to make this happen. Can anybody give me a hand with this. I’m trying to do a dancing hippo (I know, its been done, but somebody wants it AGAIN!).
I’ve attached a file with a hippo modeled with metaballs, and an armature.
Can somebody show me how to hook it up?

Attachments

HippoAndBones.blend (927 KB)

Meta object development in Blender is very limited . You cannot attach an armature (or any modifiers for that matter) directly to a set of meta balls like you can with mesh objects .

The only way you could attach it to an armature would be to directly parenting the meta objects that compose the head to the head bone, the objects that compose the torso to to the torso, etc. while in Pose Mode for the armature . So after tabbing in to Pose Mode with the armature selected you would shift select the all the parts then shift select the armature bone they belong to last and use the Ctrl-P hotkey to parent them to the bone .

But you have a very fundamental problem … you started modeling the hippo from the side view and backwards … It would be an easy thing to select all the objects and rotate the entire thing 90 degrees so that it is facing the front (you’d want this to use the mirror function of the armature), but one or more of your objects has it’s center located several BUs from others and makes this almost impossible … and this also might give you weird results when animating with the armature because of this offset . Most likely you moved the meta ball(s) to its current location while in Edit Mode …

You could convert the entire thing into a mesh and then delete one half and use the mirror modifier to reconstruct the mesh then add an armature the conventional way (after making it face the right direction and applying the rotation with Ctrl-A) …

Rigging anything requires that you understand and position your objects properly in 3D with no unwanted rotations or object centers “misplaced” . You need to be organized and understand the basics from the very beginning to get a successful result …

Thanks for your reply. I’ve decided to go the route of converting the metaball mess to a mesh. However, when I try to parent it to the armature, blender hangs up and I have to bail out. I tried doing a decimate modifier on the mesh, thinking there might be way to many polygons in my hippo. Even when reduced to a ratio of .25, it still gets hung up and requires a restart.
Below is a link to the file, just prior to doing the parent step, with the bones now in place inside the hippo.

If you’re interested, please take a look and see if you can help me through this impasse.

Yes you do have too many polys in your mesh . Instead of trying to use the decimate modifier or even the 2 reduce poly scripts available (I tried it and that also hangs Blender), I think you will get better results using Retopo to produce a low poly version of the Hippo . Or model something similar from scratch and use the shrink wrap modifier to fit to the shape and apply the modifier for the new mesh .

For something this cartoony you should be able to get a poly count in the hundreds when using the subsurf modifier, not in the tens of thousands .

I thought I might have to punt on the metaball approach, so I was already working on a hippo made from spheres, cylinders, and then joined into one mesh. Hmm. This doesn’t seem to work either. Can’t get it to hook up to the armature using “bone heat”, which seems like the best way to go. If you have time, I’ve attached the file.
This would be a bitch to do by extruding, I think, but maybe that’s what I’l have to do…
Probably still too many polygons…
I’m not sure how to go about doing the shrinkwrap thing you mentioned.

hey blendasaurus,

Just want to let you know that the arm, leg, and head bones in your character have ‘deform’ disabled. To re-enable it, select them all (only the ones that are disabled) and press shift+w->deform to toggle them back on. After that the weighting should work as expected.

Also, here are tutorials on the retopo tool and using the shrinkwrap modifier.

Thanks for pointing that out about the deform paramater. This helped.
However, I’m still in a quandry about how to go about modeling this hippo. Metaballs don’t work. I don’t really like the way it looks when using spheres and cylinders, etc. and this will probably end up with too many polygons too. Even when I join them into one mesh, the sculpt tool doesn’t do anything on them --even though the armatures now move the limbs, thanks to the suggestions Ive gotten here. I’ll check out these tutorials you suggested.
This is a lot harder than it looks!


http://www.blender3d.org/e-shop/images/creature-sample_mesh.avi
http://www.vimeo.com/1160369?pg=embed&sec=1160369
http://www.vimeo.com/1048354 (I would skip the using triangles part though, unless you are making game models)
This oughta keep you busy for a while, as simple as your model is you may want to rebuild it in a neater manner.

Thanks for the links, Jay! I’m checking them out…

I can’t get the retopo feature to work. I’m in 2.49b, Windows 64 bit system.

Here’s what I’m doing.

  1. I have a high poly model that I want to retopo.
  2. I create a cube.
  3. Go into edit mode and erase vertices on the cube.
  4. Select “retopo” from the edit menu.
  5. Cntrl Left click on the model to start creating points.

NOTHING HAPPENS.

I tried it in solid mode, shaded, wireframe. Not happening.

Did I skip something?