Animating particles along Curve Guide

I am trying to animate mesh particles controlled by Curve Guide. For unknown reasons the particles generated move along the curve with changing velocity and my idea is to make them move with constant speed. How can this be done? (all speed options in the emitter are set to zero and the Speed IPO of the curve doesn’t seem to affect the speed of the particles too ).
Thanks in advance!
Here is the test animation with the problem (141 KB, AVI, XVID)

What curve type are you using?
Are you sure that you’ve set it to Uniform U (Edit Buttons > Curve Tools)? otherwise, the hash marks (those little arrow head thingies on the path) could be stretched/compressed along your path; maybe that’s what’s causing your arrows to speed up/slow down while they travel along the path.

Thanks for reply JarellSmith!
I am using Bezier Curve. After your post I tried with NURBS and Path curves with Uniform U option. Unfortunately there is no change in the particle behaviour. It looks the same (repeatedly acceleration and deceleration of the motion).
Maybe the problem is not in the curves?

Edit : After asking that rethorical question I looked back in Particle Emmiter settings and activated the Bspline button. That solved the problem
Video here
The only info in the Wiki manual about this button is:
Activate the Bspline Button. This will use an interpolation method which gives a much more fluid movement. :eek:

I’m glad to see that you solved the problem.
Sorry that I wasn’t any help :o

According to the old Blender Book by Carsten Wartmann:

Bspline : Use to create a soft, flowing line of movement using a spline-based interpolation of the particle movements.

I guess by default it is using a linear interpolation of the particle movements?

As a matter of fact you helped me by pushing me out of looping around the curve “suspect” :wink:
The next step is animating the transparency of the arrows. I can’t figure out how to make the arrows fadding out at the end of the curve. Animating the Alpha value of the child mesh (the arrow) makes every next particle mesh to be more transparent than the previous one. It’s not like with the halo particles…

Problem solved!