Animating stent deploying from catheter - key controlled by the distance of a control object

I’m animating a stent deploying from a catheter and am stuck trying to figure out how to get the stent to animate from being small to fully deployed. I set up a key state for the small state, and I set up a driver with a bone controlling the state changing so when the bone moves towards the stent it gets larger. The problem is the entire stent is affected, and I need the enlarging to happen only as the bone gets close to the vertices of the stent, so part of it will be fully deployed while part of it will still be small. I’m attaching my file. I had hoped that the distance option in the drivers options panel would be the solution, but it doesn’t seem to be. Any help would be much appreciated, and if someone has a better solution than using drivers, please let me know. Thanks!
Here is what I’m trying to accomplish (done in 3DS Max):
Here is my file:

Shapekeys are basically all or nothing-- per-object, not per-vertex. So you are driving the shapekey by distance, but for the entire object at once.

What you can do to make this per-vertex is duplicate your mesh and surface deform from the duplicate, to turn your shapekey deformation into modifier deformation. Then you can use a vertex weight proximity modifier to control a vertex group you use to modulate the surface deform:

1 Like

Thanks for the reply! I went to set this up and ran into an issue. The vertex group for the surface deform modifier is missing. I tried using the mesh deform modifier instead, but that doesn’t work. Thoughts?

I installed 2.83 and the vertex option is in the modifier now. The problem is I think I’m missing a step, I have it set up the same as you, but it’s not working. Do I need to have a key setup for the small size? Here’s my file:

In your pic, the surface deform isn’t bound. Look at the bind button. You may need to read a bit about the surface deform modifier or play with it some. The meshes should be identical (shape key + world position) at time of bind.

Thanks. To save some time, would it be possible for you to send me the file you edited?

Nevermind! I got it working. The binding step and having them in the exact same place was the step I was missing. Thanks so much! I’ve been trying to figure this out for days. Not even kidding. :smiley:

I would’ve uploaded, but the file was too big-- in any case, it doesn’t really demonstrate the bind process. Glad you got it sorted out.