Animation goes haywire after export

I am experiencing some problems with an animated model exported using a cal3d export script. In blender the animations work as they are intended. After the model is exported and I use the crystal space viewmesh application to view my model. When I add an animation to see the results, the model deforms in an odd (i.e. hilarious) way. To add more context I will include the end results from both blender and viewmesh.



Anyone have some ideas for me? I could use the help.

  • willjm

Try clearing the bone roll angles before export.

  1. In edit mode select all bones.
  2. Armature–>Clear Bone Roll Angle (or CTRL+N)


I tried the suggested steps and didn’t see any new results. Any other suggestions?

I am still having problems figuring out what is happening to this model. I have tried clearing the bone roll angles and that has not helped. Is it possible that the coordinate system is messed up somehow with old information? My model has an animation to wag it’s tail left to right. When I preview the exported model with the animation I get a forward to backward motion with the table. I will attach a link to download this model. I’m trying to wrap up my thesis and I could use help to get this model functional.