Animation in viewport is perfect, broken when rendering


I just started using the free addn Spring bones

It work like a charm,easy to use, make jiggles and even collisions. In viewport the animation works just perfectly,it even loops 100% perfect,however , it is impossible to render this perfection,it barely even work once the animation is rendered.

You are supposed to NLA Bake but it just does not work in final rendered animation.

Anyone knows how to keep these transformations in viewport in a final render? (the addon make selected bones jiggle,i try to find a way to keyframes those,but all Baking i try do not do that)


I’ve been dealing with this problem too. how did you figure it out?

What’s up guys, I’ve been having the same problem as well. Did anyone find the solution to this?

I couldn’t have phrased the question better, the viewport animation looks perfect, but the Render is different!

The way I’ve baked in the past was pose -> Animation -> Bake Animation -> Unselect “Only Selected bones” And select Visual Keying, and at the bottom of that panel, I make sure the baked data says “Pose” Upon finish baking the viewport animations looks perfect…But sadly in the Render, the Spring bones distort the mesh and simply don’t work.

Any solutions or workarounds that have worked for you guys, be sure to let me know!

Even the wobble bone add-on doesn’t seem to work for me either, so it’s been very difficult to get an organic wiggle.

I just want to make a Tifa Lockheart Catfight! Jiggles are important! :"(

I figured it out.
Select your armature then go to pose mode then do these settings
Annotation 2020-06-29 010604 Annotation 2020-06-29 010730

Hey!! I appreciate the response!

I tried this out and I have a question. When checking the box 'Clear Constraints" The jiggle no longer happens.

When you select the armature, do you select the entire Armature, or just the bones that have the spring physics applied?

We could exchange e-mails! I could really use your help!

[email protected]

Sent you an email.

Also having the exact same problem, was a work around found? :frowning:

The workaround is to export it as an .FBX and then reimport it into your scene.

Once your are happy with the animation in viewport: select armature and object > file > export > .FBX > check “selected objects” , check bake animation > Export FBX. Then import this file into your scene.