animation-lighting problem

ok, I have this single mesh that’s “floating” in space. All I need is for the camera to rotate around the mesh. However when I render it, the light on the mesh is really screwed up. it flashes black/dark triangles randomly on the mesh, even though nothing changes except the camera’s position. how do I prevent this:confused: :confused: :confused:
I’m not going for anything special, is there a way to get the same lighting effects in shaded mode before render?

I had this problem just last night. However i really don’t know if its the same problem.

My case:
I have a tank that my brother modled. Its 20k polys and some are small. I’m rendering to 640x480 res. Small enough. Here is the fixed animation:

So When i first animated I got the problem you descibed. In my case it was because the material was set to smooth. I think when the polys are small compared to the pixel size or just small there is a numerical issue on which vertex get interpolated for the normal affeting the shading. Turrning off smooth (aka set to solid) fixed it. Or if you leave it smooth, disable normal flipping and turn off double sided polys. That worked also.

In EDIT mode, press CTR-N (“Recalculate Normals outside”) and see if that helps.