Animation Nodes, Sverchok, Generally Speaking

Animation Nodes has a port over to 2.8, as does Sverchok.

Not sure if this is more about the addons than in conjunction with 2.8.

Since, ultimately, the goal is to incorporate them into 2.8. I thought I’d add this here.

There are simple tests for Animation Nodes and Sverchok 2.8, under youtube.

I tried the simple test using Vector Wiggle. Then, for fun, I tried to render it.

It crashed.

Tried it several ways. Not sure if it’s a beta thing. If so, WHICH beta?

Tried it on my laptop, same laptop, using 2.79. Not a problem.

In Sverchok, I tried, creating a torus knot, simple trefoil, using 2.79. Copied and pasted it over to 2.8. Applied simple node structure: Object in, Bevel, Viewer BMesh. Nothing taxing.

Again, crashed my system.

Also, not a problem in 2.79.

They’re ALL in beta right now. So, I’m not complaining as much as reporting the behavior.

Maybe it’s a matter of settings. Maybe it’s a matter of my system’s limitations.

As I said, both work with 2.79, but both crashed using 2.8.

Since they’re all in beta, there’s really no pointing fingers at the addons or Blender, explicitly.

Just adding it to the mix.

If there’s anything anyone thinks I can try to see if it makes a difference, let me know.

i could render a animation with AN a few days ago, but sometimes it crashes but i could render the whole thing with eevee, today i created a new animation and it can’t render, the trick to have the render is to do the viewport animation render ( 3d viewport, " view " menu )

Hi. my personal problem is my linux drivers for radeon video adapter. eevee not works at all. Cannot solve it in current state - old adapter and new linux and new blender…
Sverchok is permanently under development mostly by zeffii now. And he is doing really great job.