Animation not working from Adobe Maximo! HELP NOOB HERE

Hey so i download a robot form sketchfab and threw it into Adobe Maximo to get it to dance and downloaded the file as an Fbx but when i import it into blender the animations don’t seem to work they seem to be independent of the mesh! like the image listed below only the dotted lines work and move but my model does not dance any idea as to why this is happening and how to fix this? it would be of great Help!

This might take a while so grab a coffee…
First some questions…
I see the model is in A Pose…was that the original pose? (Mixamo needs to be in T-Pose to work correctly, can get to that later…)

Did you Rig the model in Mixamo…adding the armature?
Did you download the model with the animation or download the animation file separately?

What were your settings for the FBX import?

Well this is not my model I did uploade it to maximo and when I did select my desired animation it worked perfectly in the preview so I assumed it was rigged and redy I imported them normally by going to file important .fbx I’m pretty new to 3d any help would be great!

When you import use these settings on the FBX, first click the Gear Icon in the upper Right corner…then set the rest as shown here…

hey i tried the exact same setting but no luck!

What files i get when i import them:


how i download it from maximo

The blendfile

For the first model, I will download the FBX with Skin…then I will go back to the model and add another animation, and download that one with-out skin…( repeat for all the animations you want).
This gives you 1. your model with 1 animation (rename it) and a second armature with the 2nd animation ( re-name that one to a rememberable name).
I also do a search for “T-POSE” and add that to my model, then download it without skin ( needed to be able to use the plain animation files).

In Blender…I import the First download model with skin as well as the animation, once imported, you just hit play on the timeline ( write down the animation frames from miximo and change the ending frames in the timeline ).
It should play just fine.

NOTE: Start-Over. Do the above…*If your character had an armature or anything but the mesh delete it…Just send the model only to Mixamo…go through the placement of the chin/wrist/knees etc. *
I checked your model…1> It had no armature or armature modifier. It had no bones, it looked like it had been changed from the original Mixamo download as stated above and tried to convert to Ik or something…which was not parented to the mesh…

I resent your model to Mixamo, added the rig and animation, downloaded with skin and this is what you should see after importing the FBX…

hey thanks it did work out now i have another issue when i upload another model to mixamo it does not animate properly there is a gap between the hand and the ground plane any idea why?

i have been having the above issue i thought it was to do with the rigging but i rigged it using mixamo’s auto rigger and still seems to not be right any way i can fix this?

Did you use the same model and just add another animation to it?
For a wild guess, I am going to say it is because the original object is in the A pose and not a T pose…so when you use the model for an animation that is configured for a T pose the arms are a distance away from where the animation is set…causing it to miss the floor…best fix…add in a plane, move it up and call it the floor. don’t worry about what shows on Mixamo…fix it in Blender…

You can fix the Model ( or rather try ) by downloading the T-Pose animation file…add it to your model and download without skin…you have to use the Action Editor to replace the original armature with the T pose …I have done it before…but since updating to new version of Blender…I can’t get it to work anymore…I Will see if I can get it to work and let you know…