Animation playing Backwards?!

Hello there!

I have another problem.

Ive finished the result of a blender guru tutorial. http://www.blenderguru.com/create-a-shattered-glass-title-animation/

But I cant get my animation Backwards. At the end he says you can do it within blender???

WMP cant play backwards. And I have downloaded a spanish version of MAGIX so that doesnt work either. Al the other torrents seem to be incorrect, infected or incomplete.
Can anyone help me with getting my animation played Backwards?
I count on you guys!
You already helped me much and fast!
:cool:

Not that experienced with the sequencer, but a quick look at the wiki user manual gave me this:
http://wiki.blender.org/index.php/Doc:Manual/Sequencer/Usage#Reverse_Action
And it works in 2.49… I was unable to load an image sequence into blender 2.55, those features may not be implemented yet…

Randy

You just want to play an animation backwards? That’s easy:

Open Blender 2.5 (should work in any blender 2.5 version) go to Video Editing (at the top where it says “default”), or just open the Video Sequencer Editor in one of your windows. Click on “Add” and select movie for movies or Image for images (sequences). If you rendered your animation as images and have something like render_0001.png, render_0002.png, … just select all of them (like in the 3d editor with shift or just hit ‘a’ if they are all in the same folder).
You now get a bar that represents your movie/images. Grab it (g) and move it to frame 1 to the left. On the right you have some settings. On of them is under “Filter” the option “Backwards”. Just check it and your animation is now backwards :slight_smile:

To render it out as a movie for example, just go to your render settings (make sure under “Post processing” Sequencer is checked) and select your output format. Be sure you render enough frames. If your sequence is 400 frames long you have to set the render settings accordingly :wink: Blender doesn’t update it automaticly.

Short:

  • Open Blender 2.5
  • Add Image strip or movie
  • Check “Backwards”
  • Render your animation

regards
Dirk Hechler

also here are a few more backwards tips

if you just want to watch the 3d view play backwards you can press the backwards play button in the timeline window

if you just want to play the rendered image sequence backwards (but not render it backwards)
you can press “p” (for ping-pong) while watching the rendered animation and it will continuously play forward then backwards, forwards then backwards
etc (press p again to turn it off and it will continue playing in the same direction it’s going)

Have you actually tried that with 2.55 DirkH? I tried last night when I was reading up on it, in 2.55 & 2.54 (official builds) it crashed everytime I tried to load in an image sequence. 2.49 handled it just fine. Just curious, was going to look into it a bit more, see if it’s a bug. Using Win XP.

Randy

it works fine for me
Mac 10.6.4
Blender 2.55 SVN

It’s even easier - just add your scene to the sequencer and chose “backwards”. Beware that you need to bake your particle cache before that, or otherwise Blender might crash…

@Raub - personally I think it’s better to render the scene and then edit it (play backwards or whatever)
if you add the “scene” to the sequencer it can really slow things down - even on simple scenes

Yes I did the same tutorial and it worked fine (but I have no idea what Blender version it was. Definetly 2.5 something, not 2.49!). I was using a Mac computer, but with XP 64bit as OS.
BUT I’m using Blender 2.55 right now to mix a few videos and images into one animation and it just crashed while I read your post o.O
And yesterday Blender only used the first video (of 3) in the final animation. I think this is a new bug in the new Blender builds. I’ll test 2.53 now…

/edit
Ok, tested 2.53 now. I just opened the file and hit ctrl+F12 and it not just worked, it was even 60 times faster. But then I realized, that the blend effects for my text (I animated the opacity) were gone. I animated them again but now it’s slow again…and now (frame ~230) it crashed. Blender just disappears, no error nothing :confused:

//edit2
Ok, tested it in 2.49 and it crashes as soon as I try to render it or scroll through the timeline where a video is. Images works fine though…
I’m not sure if it’s a bug now…maybe it’s just my file? Because you could at least work in 2.49 right?

Thanks for the response DirkH, and apologies to Boxlol for hijacking this thread…

I tested 2.53-2.55 official builds with the sequencer, upon entering the sequencer, I select add from the sequencer window, choose either a movie or image type, and the file browser opens. Then if I go to the top left hand corner of the window and under ‘system’ I select my c: drive and it crashes. If I navigate thru 4-6 directories via the file browser window, it crashes. I think I will try the latest svn build to see if the behavior is the same, and if it is I guess I will report it. I just hate filing bug reports if it’s not a bug, every one I have submitted so far has been a real bug, but if everyone else has been using the sequencer without problems…

Thanks
Randy

P.S. I am using xp as well, but 32 bit… can anyone with xp 32 bit test this to see if they get the same results?

Ok that’s odd. I can add as much as I want but Blender sometimes ignors it and renders the same image for all the frames.
But I changed the output to images for now and everytime Blender crashed I just started where I stopped and after some time I had my animation as images. With that I made a .avi file. I guess Blender has problems with too much fading between videos and images in the sequence editor?! At least in my file.

Sry, I don’t have xp 32 bit here.