Animation resets itself

Hey guys.
I encountered the following problem:
I managed to model, rig and animate 2 characters. The third however has a strange bug which might be my fault.
Whenever I try to position (rotate, locate) my Model in new poses the bone immediatly snaps back to its previous position, just like when I’d click with the right instead of the left mouse button.

This problem only appears if I choose any other keying set except “location” the moment a rotation key is involved it starts resetting again. Sadly without the rotation I can’t do anything.

I suppose this might have to do with my parenting (I simply parented most parts of the armour the the adequate bone). But even reparenting didn’t change a thing. I also tried to import it into another project which worked for the other characters with no avail. So the problem must be the model or its settings.

Can anyone help me?


Best regards Jack

you may have to post a file…

if you can’t post it directly here…

use pasteAll…

http://www.pasteall.org/

then post the site back here so we can see what’s going on with your file…

http://www.pasteall.org/blend/40203

I hope this works :smiley:

Does no one have an idea?

http://i.imgbox.com/Z0GYBZfs.png
With your rig selected, change ^that to ‘None’.

worked, thanks! :slight_smile: