animation slow down at frames end

Hello,

Windmill wings animations has 120 frames.
When I play it with Alt+A there is a nasty animation slowdown when the last->first frames are shown. That’s because the last frame is the same as the first.
I don’t know how to solve this, setting the animation to say 119 (skipping last frame) does not make it fluent.

Regards
Koto

Attachments

wind_wing - test.blend (1.35 MB)

http://www.airheaded.com/b/Wiatrak.jpg

Thank you Zavigny, that helped.
What is the best way to create such animation quickly?, preferably without playing with F-curves?

What I did was adding a key frame every 90 degrees, but it resulted with this problem of border frames.

You can set the default F-Curve interpolation mode in the User Preferences

Attachments


Thanks Richard!