Animation with audio


I have an animation (.blend file) rendered in Eevee. There’s a red flare that is supposed to pulsate in sync with the music.


Unfortunately, the flare is not really in sync with the music, and I don’t know how to improve this. Can anybody help?



I think I remember that in the timeline it used to be possible to have a waveform. The functionality is still in the sequencer though, and if you turn on audio scrubbing in the timeline (under the playback menu), you can line up things.

How did you do it? If you used Bake to f-curves then you probably need to change the audio frequency used as the basis for the pulsing.
Have not done this for years, but I remember that part of it was using audacity (audio editor) to find out the frequencies of the different instruments.
You may need to double bake - for the bass and for the oboes (?). Consider putting the low notes to X scale and the high notes to the Z scale.

Someone from the Blender meetup suggested that I animate the red flare by hand. How do I go about there? And how do I undo ‘Bake Sound to F-Curve’? Right now, it’s disabled.


Delete all the keyframes to remove the bake.

Animating by hand means adding a scale and keyframe for every beat. And then the opposing scale several moments later. And keyframing every one of them. That would get very tedious very quick unless you take shortcuts. Perhaps do several ‘beats’ or pulsations then use cyclic extrapolation to repeat forever. Channel Menu > Extrapolation Mode > Make Cyclic.
Turn on the wave form in the side panel in the audio strip window. Line things up to the waves…

So - when you did the Bake to f curve, did you open the side panel (in the browser window that appears) and set the frequencies? Working out how to adjust those settings will produce the best final result.

1 Like

I don’t know where I set the frequencies, and I can’t find this option again. ‘Make Cyclic’ is disabled. How do I enable it?



Another approach using geonodes and sequencer volume (from BD3D extra nodes)
No separate frequencies, just volume but, dances to the beat just fine.

Hope that helps.


I saw an add-on in the Blender Market that will do that.


many thanks. I managed to install Sound Nodes, but where do I go from there? I loaded the sound file & analyzed it, but how do I continue after that? I read the docs, but can’t find the nodes (Sound Info Node, etc.).


Once you have some keyframes - in the graph editor (or dope sheet) go into Key Menu > Bake Sound to f-Curves. A file Browser window opens. Press n to open the side panel in the browser window ( or click the gear wheel in the top right of the window ). That is where you set the frequencies.