Animations get broken when switching from cycles to blender render

Hi guys. Totally new here and I need some big help please! I’m working on my first 3d character ever! All thanks to the amazing tutorials at blender cookie.

That said I need some help please! I think I may have discovered a bug or maybe I’m doing something wrong.
I modeled a character then jumped into cycles to do all the texturing. I then set up a series of 25 animations (videogame character) rig and all. The animations look pretty great thanks to your tutorial. However I ran into a problem. To export into unity I needed to texture in blender render to get an accurate feel of what it would look like in unity. Didn’t realize unity didn’t recognize cycles. So I went back to blender render. I cleared any deforms in the armature. I then changed the materials from cycles by clicking the node button and went ahead and applied a regular texture image to the material. As soon as I do this my animations get messed up. By messed up I mean, it overwrites all my animations with just one. So the way my animations are set up is via fake users. Each sequence, run, jump, etc has f selected. Each animation has it’s own key frames (obviously lol). When the mess up occurs, let’s say for example I have run jump and crouch as 3 separate entries, each one maintains the key frames according to the editor but when I scroll through the timeline or graph editor the 3d display only shows me the same animation over and over regardless that I have a completely different one open that shows totally different key frames. It’s like it selects one animation and then ghosts it over anything else.

I tried restarting and even then the animations seem to have saved the mess up. I was lucky I kept saving under different file names so I was able to revert back to an older one not having lost too much. But what is going on? Any ideas? I could really use a hand. Thanks you guys!!

I could really use a hand.
I’m sure just like those who would want to help you could really like to have access to your blend file to see for themselves

Hi Richard, I’m sorry I have no idea how to share the file, if I can get some input on the best way to do so, I definitely can. Thanks!

So just an update, I tried something as simple as removing the materials (they all were node edited) completely from my mesh. As soon as I remove even one, and then I try to scroll through my animations again, they do not play. What happens exactly is that the first animation I select immediately after editing my materials, will play properly, but then this animation seems to get cached into the memory or something (my only explanation lol) and then if I select any other animation from the drop down, they all play this same animation as I scroll through the frames. Keep in mind that the subsequent animations I choose DO show the proper keyframes in the editor window, but they just do not play what should actually be in those keyframes.

Sorry also I realized there is an attachment option that allows to attach a file, but my blend file is 40mb not 15