Another Captain Blender Problem!

I am working on the Captain Blender project on Tony Mullen’s book “Introducing Character Animation with Blender”. I am currently working on page 98 - adding the “logo.png”, I am not sure what really happened here because I can see the “logo” on the preview window but I cannot see it during the render. I have followed every step mentioned by Sir Tony Mullen. Any insight? Maybe about “empty” ? :frowning:

Attachments



I had similar trouble with my first logo too. I haven’t done ‘Captain Blenders’ project but with the empty, u need to have the ‘Z’ axis on the empty pointing perpendicular to the surface. Whatever surface you want the logo on, right click it, add another texture slot and choose ‘Object’ in the 'Map Input" panel. Then type in the name of the empty next to it, probably 'Empty". It should work.
If it doesn’t, mmm…

Thank you FloorPlay.

Tried it again to no avail. Still the render don’t show the decal.

Tried it again on BI and the decal now shows! It is therefore a Yafray render problem. However, I still wanted to know how does it happen? Why the decal shows using BI and doesn’t when using Yafray? To those with the know-how about this, please let me know. I also wanted to be in line with the “know-all (?)”

Thank you in advance.

You are using the wrong image format. Yafray can only use certain formats among which TGA is so use a TGA and you are all set.

Thank you very much for the tip.

You are right. I convert the image from PNG to TGA and like a charm! My problem is gone. Decal now shows just fine.