another "maze game" related question

hi!!,a new blender noob here XD, coming from maya,etc…
and sorry for my english…im spanish
looks like when all want to learn some of the game engine, we found the maze tutorial…

so i do, and try to do by myself something more advanced, like ball rotating in a natural way,camera control by mouse,etc…

i read a lot of post here, tutorials, pieces of code trying to understand…some from here…there…
so…ah! yes…the question XD

this is my maze, and my ball, the idea is to “push” the ball in the direction the camera is facing.
the empty is vertex-parent to a vertex in the center of the ball, and the camera is children of the empty. all right, i upload the blend too…and it “works”
there are two scripts, mousecontrol and ballmovement
the mousecontrol takes the code from Phymec example of the Planks tutorial
and the ballmovement comes from a lot of yours,here in the forum,of key events and “addforce” methods,etc…

juegolaberintoblend.blend (1.46 MB)
(WASD to force, mouse to look)

but if i change the FORCE value, to some higher than 1, this happens

so im afecting the camera somehow (maybe something in the parenting? im afecting the empty,or the vertex-parent in the ball? )…
if you look at the code, i access the localorientation of the empty to apply force in that direction, the camera follows the empty…simply…
is the first time i take phyton coding and blender…so at this moment…XD i dont know what or why,this happens…
sorry for the long post guys, and thanks.

I tried it out several times but i don’t have the problem like you:confused:

so my file in your computer doesnt do the weird camera thing when change the FORCE value???

what function does the force variable have???

to control the value of the force you apply to the ball

I see! But i can’t think of any way to fix it :frowning:

if i unparent the camera from the empty object, that “stretch” camera effect doesnt appear.
if i parent the camera to the ball, the camera follows the ball, rotating around with the ball, thats ok, thats the reason why i must do the vertex-parent to a vertex in the center of the ball… ok…so far so good, i got dizzy but i see the control works, ball is moving in the direcction the empty localaxis point to…

the strange is when i parent the camera to the empty, to go along with it, and to rotate according to it… then is when the strech camera happens, if the FORCE value is higher or lower than 1

maybe i must do the parenting in another way? can i see in debug mode when the game play, the empty object? maybe is the empty object the one being affected (scaled???)

edit: also say that i reset the scales to 1 in the tree objects (ball,empty,and camera), but it doesnt help

I also tried out different combinations for example i add another object made the ball parent and the camera child and copied the rotation of the empty but nothing worked out