Another poor soul without animations happening in BGE

Take pity on me, oh great ones, for I am ignorant. I want only my fingers to flex, and yet, the fickle gods of binary look away from me, never once answering my many sacrifices and burnt offerings. Look upon me and weep.

Long story short, new to the game engine, and cannot for the life of me figure out what in the world is preventing my actions from happening.
actionless.blend (1.2 MB)

The offending .blend. I’ve looked through the other forums, and applied anything that was applicable and didn’t totally screw up the mesh. Please help.

Hey,

I fixed it for u, first of all:

  • having all actions on all key press is already bad enough if u want to test something :wink:
  • second the size is way to big for in a game engine *game building wise" (not a bad thing it is your own choice)

ok how did i fix it?

  • animations on a skeleton that is parented to the skin (hand) means that the skin(hand) needs an armatur modifier on it. So thats all i did (and removed the rotation).

fixed actionless.blend (1.2 MB)

Thank you Cotax, it does work.
-I was frustrated.
-Oh, well yeah, but I have poor eyesight, and when you zoom in too far things get janky to navigate. it will be resized.

So what you are saying is the mesh needed a empty armature modifier on it? That seems odd, but very interesting. That’s why none of the fixes worked for me, I would always put a target in. Is this just how blender works?

I have no idea how it works, someone else should answer that question.

I only know that every character that i rig, and parent the skin to it, that it ads an armature modifier.
Why its empty? becouse that was the one that worked. If u add the object your mesh deforms pretty bad(in 3d view), and i have no idea how to fix that.

Alright. Second problem on my journey, I have two actions recorded, hooked up in the logic editor how I saw in a tutorial, in a way that is supposed to loop one action until I push spacebar, play another action, than resume the original action, but, pressing spacebar only seems to stop the “idle” loop, and it doesn’t resume at all. it is likely a simple fix that I am overlooking, but, I’ll always remember the solution.hand kind of works.blend (1.14 MB)

U are not following good tutorials or u skipped a few settings. At idle put Always on true pulse. at idle put priority at 10. At empty action, put in hand action, and put priority on 9. know everything works. hold space to stop animation, release to resume. OK what happend: priority gives actions a priority meaning what action overwrites the other action. the lowest priority will overwrite higher numbers. so why did i put it on 10 and 9? i Always start there haha, idle at 10 means, hand at 9 will execute their animation and will stop number 10 from playing his action. if u put an animation on number 8 it will stop all other animations above that priority number on the same object. Hope that this clears a few things.