Any Alternative to Pose Library Addon?

I’ve tried to use the Pose Library addon which comes free in Blender, and I’ve tried to like it. But I kind of failed in that regard.

I don’t know, maybe it’s just me. It seems and feels a little complicated and clunky, especially when I try to export it onto another file with a different armature.

Is thery any alternative addon, free or paid, to pose library?

Something straight forward will suit me better I guess, since I’m not doing fancy things with it anyway.

I’m thinking of an addon which basically save rotation/location data of selected bones in an armature into one accessible data format.

I’ve heard of Face It and Auto Rig Pro, but are they easy to use? From the documentation each addon provides, though they’re absolutely looking great and pro, but they too seem a little complicated to use.


There’s Gaolib:

1 Like

Thanks for the recommendation Joseph!

It seems that the script is still in development, thus I kind of failed to install the dependencies. However it’s still great to know someone’s trying to make it.

1 Like

Just out of interest, are you on a mac?
We’re having troubles with installation of the dependencies on recent macs.

Not really, I used a Windows OS on my computer. I thought it was just me, so that I have my friend installed it on his computer (Windows OS) as well. He got it worse that it had his Blender not responding.

Are you the developer?

I developed some of it, but mainly I’m the commissioner & tester.
The main developer is Anne, and she develops on Windows, so this is a bit confusing to me.
What specific problems did you encounter?

It seems to be some scripting error. I got the error both when I tried installing the dependencies, and also when I tried removing the add-on.

Ok. Thanks for the feedback! It seems the dependencies are at fault.
Sadly we can’t do all of this with native Blender code, so the dependencies are necessary.
Alright, we’re going to try to make things smoother. Once again, thanks for getting back to me.

1 Like

Just out of interest, did you (or your friend) have the system console open when you tried to install the dependencies?
The reason I ask is that sometimes Blender asks your permission to install them, which it does in the console.
So Blender not responding could’ve actually been Blender asking you for input, but you didn’t know because you didn’t have the console open.

1 Like

No we didn’t. I’ve never got an experience with installing dependencies before, so it’s very probable to be the case. Are you still developing this add on though?

Yes, as with all software, development s a never ending process. Right we’re trying to solve these issues with dependency installation, as you aren’t the only one who’s encountered this.
Longer term we’re looking at doing the UI in such a way that it doesn’t need dependencies to be installed, but for now that’s the reality.

Ok, so I’m on Linux and have to remember how to do this. From memory, on the Windows build of Blender there’s an item in the “Window” menu on the top right of your Blender window that let’s you display the system console. This is where Blender prints out full error messages, and sometimes prompts the user with questions.
If you could try again with the console open and let me know how it goes that would be most helpful.

Image here.

Do you make the add on for personal purpose, or rather you build it for some other company?

It was made for in house use at Gao Shan pictures (the studio that animated the Oscar nominated “I Lost My Body”), and has already been used on a feature film, “Mars Express” which will be released next year. Since then it’s been used on a pilot for a TV series as well.
Trust me, it works and is really useful!

From your error message, it looks like you don’t have admin privileges on your system, so it’s not letting you install the dependencies. I’m not sure how to solve that from here, but if you can figure that out, it should work for you.

1 Like

Running blender as an administrator should fix the permissions issue