Any easy way to fix the normals?

Is there some easy way to fix the normals directions, instead of selecting individual face and changing its direction, when the current ones cant do it? Maybe some command -> select::in, select:: out normals and then recalculate, that would do it.

Hi, select all faces and press Ctrl + N , this will recalculate the normals.

Ctrl + N will recalculate the normals selected.

Im sorry, i guess i didnt said it correctly. One from my normals is inside and outside. Thats the tricky part, so the ctrl+N dont work. The solution is to select the flipped normal and recalculate them, but that is a slow process. You have to select every each one of them and i dont like that. So is there any easy way to do it?

Upload a blend file and maybe we can figure it out.

One of your normals is both inside and outside at the same time? That’s impossible. Sounds like you have a bunch of duplicate faces.

Shrodinger’s Normal… It is both in an out. It’s in super position. :smiley:

Since words did not help, heres a video:
Ive downloaded the blend from here:

That model has crappy non-manifold topology. There is no clear inside or outside because of this. The best way to fix it would be to retopologize this into something with proper manifold edges.

Here are couple of things you can try.

  1. In object mode if you have non-uniform scaling ( x = 1 - y = 0.5 - z = 0.3 etc) apply scaling (ctrl - a > scale ) and then try to recalculate normals in edit mode.

If that doesnt work.

  1. On the Properties panel - shading - enable Backface culling so we can spot flipped faces easily. Then select a flipped face and use “Select Linked Flat Faces” ( ctrl + shift + alt + f) . This will select the flat faces connected to the face you select which have a flatness of (n) value. You can change the flatness angle in the tool shelf, attributes panel. set angle number between 30 - 60 and it should select the faces sharing the same angle ( and up to a point same normal : I say up to a point because if you use a high number close to 120 you will select the front faces also).


None of that is the problem. The problem is that it has edges with three or four faces attached, so there is no clear inside or outside to the mesh, so the normals near those points don’t know where to go. The best you can do is manually flip the faces that are wrong one by one, but even that will still end up looking screwy because you’ll still have those non-manifold edges. The solution is to fix the mesh.

Thanks for the info. Isnt there some python script, that could fix the normals too?

I don’t think you understand. Even if the face normals are all facing the way they should, you will still get shading artifacts because of the vertex normals. Some of those vertex normals are going to be wrong no matter where they are facing, because you have non-manifold geometry involving edges connected to more than 2 faces. If you don’t give this proper topology, you will have shading artifacts. There is no direction those vertex normals can possibly point that will not give bad shading results with the mesh as it is currently. A python script can’t “fix” these normals because with this geometry there is no truly correct direction for them to point. You have to either A) accept these normals as they are, or B) fix the mesh itself.

There’s a ‘Select Non Manifold’ option in the select menu, that you can use to see where the problems are, and correct them.

It’s obviously a game type model. It’s made like it is to keep the polycount low. Why don’t you just enable double side faces in the vertex menu. It should render alright then. Of course if you are exporting this to a game engine like Unity this may be different.

There are ways to model this without the three-face edges without increasing the polygon count above the game’s budget. One easy way would be to separate the geometry (e.g. split the legs from the torso at the waist so the coat is a straight piece. Solidifying the lapels may be necessary, which will increase the polygon count slightly but should still be within budget. If not, you can separate the chest and neck from the coat and overlap the geometry to hide the split.

BTW, Select Non-Manifold will also select open edges, but they are not the problem. There are two types of non-manifold geometry: edges connected to fewer than two faces and edges connected to more than 2. More than 2 is the problem here. You have those around the waist, the lapels, and the base of the cuffs. That is what needs to be fixed.

Thank you, all of that helps and yes its for a game.