Any way to edit without edit UV:s?

Hard to explain.

I have six grass/flower-objects in one collection and train to “plant” those to plane with weight paint and hair particles. To get those in right angle was very, very hard, but then fixed it using edit mode: I could see what is happening.

After turned all six objects to right angle I started to wonder how object looks very strange. It take looong time to figure that error was that I used edit-mode; it ruined uv-mapping of objects or textures, I think.

I tried to get exact numbers (x/y/z rotation and place) in edit mode then in object-mode give this number and then applying all transforms. This looks like working, but is very hard, is there any better way?


Turn on “Correct Face Attributes” in your Edit Mode Options menu

Thanks, but it not helps.


Before rotating in edit-mode (Correct Face Attributes - activated):

After rotating in edit-mode (Correct Face Attributes - activated):

UV:s before:


r
AFTER:

This is so hard to understand why this have to be so hard!? Every time when I make some changes in object (object-mode because in edit-mode texture is ruined) and add transforms, then the pivot point is going very strange place and every time have to set origin to center of mass. To rotate one object to right rotation it takes about 0.5-1h. :face_with_spiral_eyes: :face_with_spiral_eyes: :woozy_face:

Why Particle system can’t get hair objects straight, if it straight when appending to Blender?

rotating should not affect the UVs at all. can you show us how you’re setting up the material? maybe a copy of the scene?

1 Like

It doesn’t affect in object-mode.
Most of them are assets. There is one:

Correct Face Attributes is what CAUSES this BS, better disable it. Nothing suspicious in your shader nodes, they use UV, not object coordinates. Could there be some modifiers that affect UVs?

1 Like