any way to stop twinkling stars?


(EnthroneD) #1

is there a way to stop stars from twinkling when the cam sweeps across a starfield?


(blengine) #2

i got that before too =\ a lil annoying… but if its just a camera sweep… render a REALLY high resoultion picture of a starfield, and uvmap it on a long big wall and put it far in the background, but make sure its covering the whole camera view…
if u want a whole surrounding… render a smaller starfield with alot less stars, and uvmap it on a sphere… instead of mapping the sphere “from window” just use the original 1X1 setting so the starfiel is mapped onto EVERY face of the sphere, that way there is no weird uv strecthing…

size the sphere up really high too…

i hope this helps


(EnthroneD) #3

hi and thx…
i tried that…unfortunately same results. mabbe its the tex size or settings…but i’m still stuck. suggestions anyone??


(S68) #4

If stars are smaller than the pixels some twinkink is very difficult to avoid

You can try with an Iconsphere Subd 3

Fract Subd it twice with some high value

Add an halo material

Stefano


(EnV) #5

Anyway, if you look in tv series like Star Trek Voyager, stars on the background twinkles, too…

Env


(malefico) #6

Are you rendering at 100% of your resolution or making previews at 75 or 50% ? I had some troubles with that in the past, some textures looked wrong. Just an idea.


(theeth) #7

just increase the clip end value of the camera. Stars twinkle when they enter and leave the clipping distance.

Martin


(Timonides) #8

Hey I had this problem once with a test animation I did… but I didn’t figure that this was the reason for the twinkling stars…

Thanks Theeth… :smiley:

Spyros.


(theeth) #9

Hey I had this problem once with a test animation I did… but I didn’t figure that this was the reason for the twinkling stars…

Thanks Theeth… :smiley: [/quote]

no prob!

little word of warning though. When you increase the clip end, the number of stars on screen will also greatly increase, so be sure to increase the distance between stars.

Martin


(Superdan) #10

Stars twinke on TV because of the NTSC field effect. The NTSC standard calls for odd and even fields. When a star crosses slowly between adjacent scan lines it will be missing in one field and then the other. Some people like this effect, but I want my stars to twinkle only when I say twinkle!


(EnthroneD) #11

Hey I had this problem once with a test animation I did… but I didn’t figure that this was the reason for the twinkling stars…

Thanks Theeth… :smiley:

Spyros.[/quote]

tried that…alas!!! still stuck…but thx anyway.


(LukeW) #12

If you haven’t done it already, you can change the OSA (oversampling) to 16…


(RipSting) #13

The best solution that I’ve always done is to use motion-blur. When you enable motion blur you probably don’t need to turn it higher than .1 or .2. Also, it will look good even if you don’t use OSA when rendering with motion-blur because it basically does multi-sampling.