Anybody know what causes this?

Two questions.

1.) How do I post an image in the forum?

2.) I’m currently rendering just a basic metal part with all flat faces and all quads. However, the quads are rendering as two triangles. Anybody know what causes this and how I can fix it? (I’m sure I’ve over looked something simple.)

Thanks.

Insert image: ![http://image_url](http://image_url)

Just paste the URL to the image,
hightlight it and hit the Img button.

http://imageshack.us/

is where many post their images

hmm, on a truly flat face I can’t get triangle to render triangles. ? Must be some curvature?

Alt-J converts tris to quads, hit that a couple of times.

Try closing the scene and starting a new plane, add the same material and see if that causes similar abberations.

Can’t really say, never had the experience. :slight_smile:

Did you “set smooth” and perhaps “auto smooth” in the edit buttons?
If not then try those. As a last resort your could check whether all the face normals are pointing outwards.

Remember every quad is actually rendered as a tri. That’s just the way it works. That’s just a technical thing that we normally don’t notice.

So also… the less “flat” your quad is… the more apparent it will be that it’s rendered as two tris.

Thanks for the link to imageshack. Here’s the image of the part:

http://img304.imageshack.us/my.php?image=randommetalpiece3ew.jpg

http://img304.imageshack.us/my.php?image=randommetalpiece3ew.jpg

well simple… your quads are not flat shapes… so they’re bent at the edge between two verts. And when they’re not smoothed this means they will render as two distinct tris.

Make them flat!

Or smooth them with autosmooth on and see what happens if you play with the angle value for auto smoothing.

Another option would be to use subsurfs with creases… but that shouldn’t be nessecary.

It kind of looks like you don’t even have quads there. Can you post a screen of the mesh or the blend?