Anybody use Blendertools from Nicodigital.com?


(Adrian) #1

Blendertools is a network rendering app and takes the images (jpg) and saves them into an avi.
Its the only one i have found that i can get to work as a network renderer; however i have run into some problems with it…
i use winxp pro and it renders on multiple machines just fine but when it comes time to send them back to the originating comp, i get a save error and on the rendering comp i get a file sending error. i have also posted this in nicodigital’s blendertools support(english) forum but i still cant seem to figure it out…
i have tried running blendertools as an administrator and also changed the permisions on the save folder but nothing seems to help.
the only thing i havent tried is to manually assign ip addresses to each comp and try that but then i loose internet access as i run dhcp from my router for the computers and i dont feel like waiting on hold forever-and-a-day to talk to my isp’s tech support to find out the dns numbers.
any help on this is much appreciated.
BTW, nicodigital has a link to elysiun.com on his site :slight_smile:


(IMProvisar) #2

You say you run DHCP from your router, or your ISP’s? If you have a home router, your router gets the info from the ISP via DHCP, and you have a decent one, you should be able to log into your home router and get the info. With my Linksys, I was able to do it on my old ISP (cable), but not with my new one (DSL) because their DSL box has no DHCP (the router also has an internal private IP, 192.168.1.2, so I can’t check it to see what my current IP addy is either). So check that out, and you may not need to call. :slight_smile:

Imp


(Adrian) #3

ok heres the deal… i have my own router/server computer for my network (very cheap old amd k62 128mb ram and 3gb of disk space…
i use it to run dhcp to my network. my isp (dsl) uses dhcp also for the modem but the isp side of this equation doesnt matter as the problem lies in the lan side. i can get blendertools to send the blender file over the network to one of the other comps, it renders just fine, but when it comes time to send the file back to the original comp, i get a send error in the client software and the server part of it says it cant write the file to disk. i have the firewall off on both computers (winxp) and fiel permisions on the folders is set to read/write. what im trying to find out is if i have to manually assign IP addys to each comp on the lan (minus the router) in order to get this to work. unfortunately i cant seem to get the dns daemon to run on the router comp so i can use it as a dns server for the lan; i have to rely on the isp’s dns numbers for internet access on the lan if i manually assign IP addys to the lan comps. this problem is really frustrating me because the comp dictating the rendering to the lan can send the blend-file just fine, but when it comes time to recieve the rendered jpg files back to create an avi, i get a send error on the comps doing the rendering.


(S68) #4

There is my network renderer

http://www.selleri.org/Blender

in the ‘scripts section’ but you must have a real Operating System to use it.

You need:

  • Perl 5.6 on at least one machine
  • rsh daemon on any machine
  • Yup, blender too…

Perl for windows www.activestste.com
UNIX tool for Windows www.cygwin.com (not sure rsh is there though)

Stefano


(IMProvisar) #5

Doh… I figured it was just one of the cheapy little boxes, like my Linksys… yeah, I wouldn’t know where to start looking on a Linux box to see what your ISP’s DHCP is dishing out for DNS addys.

Imp


(slikdigit) #6

s68 that’s cool! I use a real operating system (though one of my boxes is NT) I’ll give your perl script a try. I was just gonna render different frames on different boxen, but this seems cooler.


(S68) #7

Relax… my script too renders different frames on different machines…

up to now it is quite brute-force and does not make load balancing, but I’m writing a Perl/Tk GUI in my spare spare spare time :slight_smile:

Stefano


(Claws) #8

Hey - just budging in on the conversation :slight_smile:

on linux you might find the DNS’ in :

ifconfig

cat /etc/resolv.conf

(aditionally install “netwatch”)

netwatch -e “internet interface”

…and look for the (probably) first address that appear…

But if you run a linux server as router for the LAN, why don’t you set up IPtables to masquerade your LAN and give your hosts a static ip - as in “192.168.0.*” if you think thats the problem.

my 2 cents