anyone hving troubles with ubuntu and laptop?

So i have this nice laptop, dual boot it with ubuntu and windows. windows can’t treat the fn keys like it should, instead it reverses their function when numlock in enabled…
So using blender in windows isn’t very usable because it’s to akward to keep toggling numlock.

but we have ubuntu right?
not usable either, because when you’re in editmode, everytime you perform an operation which entails grabbing, scaling or rotating something, blenders crawls to a halt.
And it drags other programs with it. vlc, firefox songbird, pidgkin, whatever…

Does anyone know of a way to get blender to work well again on linux? I’ve been ignoring it so far, but it’s really starting to piss me off now. Not to mention it’s making it a hellova lot harder to edit bob for the blending life contest.

i can feel your pain.
im not a linux guru, i just tweaked everything “keyboard” related under systems/preferences and systems/administration untill i got it how i wanted (basicaly i turned every fancy stuff off). it required a few trial and error and reboots but i have the keyboard layout working now how it was under win and im a happy man since. (ie: in edit mode my blender main window doesnt moves with panning undocking itself from the screen, the 3d viewport does now). cant say much about the fn and win related keys either, they never worked for me under linux…
good luck! :slight_smile:

FreakyDude: I’m guessing that thing in Edit Mode is probably the graphics drivers. Try updating. I have the same thing with an nvidia card. It only intrudes occasionally and I can’t seem to find the time to compile. I’m hoping Intrepid has a shiny new update waiting for me.

EDIT - Not on laptop though, on desktop.


Not sure about your problems but Ubuntu works great for me and Vista as well and Ive never had a problem with the Fn keys although mine is more of a mobile desktop than a laptop.

Well I do have the latest glx official Nvidia drivers (not the native ubuntu driver), I’m going to try it out, but I don’t expect any miracles from it. It’s just so bloody frustrating…

Whoa! You compiled the Nvidia driver and it still does that? Maybe you want to go back to an older driver.
What card are you using anyway?

Hey there FreakyDude.

I’m also using Ubuntu Linux, on a Dell Latitude D620 laptop.
The Ubuntu install went pretty much flawlessly for my machine. I seem to remember the drivers working pretty much straight off.

To cut a long story short, I did botch my graphics drivers once (had the experimental repositories enabled and ran an update - ouch) but I got them going by installing a package called “envyNG” and running envyng -g from the command line (also adds itself to Applications >> System Tools menu). This cool little program was able to auto install the Nvidia drivers correctly, right down to detecting which card I was using and reconfiguring the kernel.

Blender was able to be used full power (including GLSL etc) after that.


can you give more details about your config?

I am running blender without problems on a couple of laptops: one is a hp dv9010us (with kubuntu 8.04) and the other is a dell m4300 (with kubuntu 8.10). on both accounts, compiz is enabled and I enjoy all of the eye candy kubuntu has to offer.

the nvidia drivers i have on 8.04 is the glx-new and on the 8.10 is the version 177 - both installed through adept/apt-get

Actually thanks to a hint from bassam on his blog, i found out about the envy driver as well. and that so far seems to have solved my issue. Installing the new driver initially made my screen go to 640x480 and jump to the lower-left side of the screen, so I couldn’t reach anything, but by carefully counting i got to sudo nautilus, got to copy my old xorg, and pasted it in the new xorg. Did a reboot, and whammo, stuff works again.

The weird part is that I’m used to going back to xorg whenever there is a problem. I search google for answers, they lead to sites mentioning installing this or that, and once installed run this or that only to find that all it does is write something into xorg. I´m such a noob with linux, but I love xorg.
By the way, does anyone know how to get linux working on a second monitor? say a tv? I have been able to get a seperate X screen visible, black/white only, but I can’t seem to do anything in that screen other than moving the mouse around in it.
Bassam’s on the next ubuntu apparently, and i read it’s supposed to be very scalable and should work very well on notebooks. I’m going to upgrade to that once it’s out.

After envyng, you shouldn’t need to manually edit your xorg.conf file. See if there’s a program listed in System >> Administration >> NVIDIA X Server Settings

If not, install nvidia-settings

This program allows you to specify screen resolutions, as well as dual screen setups. I use it all the time to get my projector to work.

A small hack though: Often I find that if I’m going into another school, the projector isn’t detected (by name). If this is so, I can configure it to work but only ever get 640x480. The solution is for me to plug my own projector in, and get it to detect and run at the 1024x720 or whatever I want. Then I just unplug my projector and pop their one in. Computer still thinks it’s running mine and it works fine, occasionally needing to change the Hz frequency to dump flickering or screen waviness depending on model.

yeah I know but even with sudo nvidia-settings, the config application doesn’t always write to xorg, OR it overwrites xorg and deletes all my manual edited settings. Menolikethat. So i just have the nvidia settings create the xorg, look at the preview, copy everything in it, paste it in teh real xorg and start editing out what I don’t need.
For tv I was just thinking any random tv really. My brother has this bigass last-gen tv which he got very cheap of the internet. One of those people wanting the very best and once it’s no longer top of the line they dump it, that’s where he got it from. And then my parents tv, and some tv’s my friends own. Most of them have got a laptop, and they either play dvd’s with them, or game on a large screen.

They use windows and mac. It’s just plug and play for them, but that seems to be a nono on linux so far. I have about 3 different xorg files dedicated to trying out different dualscreen modes. The best one gave a black/white seperate X screen where I couln’t run anything in it. The second best stretched my desktop among the two screen and would not let me maximise an application or window in one screen only. When I do autodetect, it ussually detects the tv, but I keep getting a message in the terminal:

Initializing nautilus-share extension
seahorse nautilus module initialized
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' gaf fout 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error Bestand of map bestaat niet
Please ask your system administrator to enable user sharing.

** (nautilus:18569): WARNING **: Unable to add monitor: De bewerking is niet mogelijk

EDIT: I get this message when I do sudo nautilus, not after running the nvidia settings btw.

I tried ubuntu and I could not get BLender to install correctly. I got an old version from the repository to work. I just don’t understand why the builders of blender do not make an installer for linux like they do with windows. When I downloaded the linux version and unpacked it. I would click on the icon and nothing would happen. Linux still needs to catchup with Windows in this regard. The stupid person, like me, just doesn’t get it. And what is more important is I don’t care to get it. If you are going to give me an icon from a download. Make it so it launches when I click on it. And I don’t want hear replies like all you have to do it type “blah, blah blah” in some console somewhere. That is what the installer should do for me.

Hi Atom.

I used to use the Ubuntu repositories and install Blender through Synaptic… but then I got tired of them always being behind the latest Blender versions, so I decided to download “the real deal” from

It is… very much… just double click and run.

The Linux version is just a zip file. Right click on is and choose “extract here”.
Go into the folder it makes. Double click the icon labeled “blender”.

…no “type blah blah blah” at all.

When I downloaded the linux version and unpacked it. I would click on the icon and nothing would happen

That might happen when you extract it to a fat32 partition, as fat32 has no management of user rights. Copy it to a native LINUX partition and you will be able to make it executable.

购得乐网上商城(以下简称“购得乐透光云石”)做为网上交易平台提供者,并不直接参与网上交易透光云,同样也不会承担因交易引发的任何责任。透光云石但购得乐会尽可能的对店主身份的真实性进行合理的验证,以维护购物者的合法权益。 2.经过购得乐认证的店主,透光云石并不表示是购得乐对其信誉的认可,请一定要谨慎购物,若出现任何纠纷,购得乐会在职责范围内提供商家透光云石相关信息;若是在未认证的网店购物引起的纠纷,购得乐不负任何责任