anyone using blender, wacom and ubuntu 10 04 yet?

just curious because it’s only 6 days 'til release…

…and hal has been removed… so I have questions:

  • do wacom tablets just work (eg intuos 4) or do you need to manually adjust?
  • do they still “hotplug” without hal?
  • does blender 2.5 still “find” them and allow pressure usage?
  • any other "bumps2 to get over?

I have a wacom intuos4 m and I really interested to know HOW I can use it with ubuntu…

follow :slight_smile:

I have ubuntu 10.04 beta 2 installed and currently getting the system to run. The ‘wacom and blender’ is on top of my testing list.

I will report later this day ( I’m am currently at work) about how this new combination works out (using a graphire4 with bot blender 2.49 and 2.5)

at least in the ubuntuforums it is stated that it should work with the newest wacom driver.
and HAL is not just removed but replaced by DeviceKit which does the same but more efficiently

HAL always needed to be configured in my experience… wondering if device kit’ll just work or if there’ll be the usual pain of trawling the net!

could you explain what youve configured? ive never configured anything and it works just fine.

I had to do a custom fdi file to get inputs called the right things (stylus/eraser etc) so that wacom tools and wacom cpl would work (and blender 2.49)

…and also i had to do a different fdi on my tablet pc to get “touch” enabled…

you had to write this custom fdi file because wacomcpl didnt show the tablet, right?
then this could also be fixed:

the last commend sais:

Should now be fixed in lucid. At least, we no longer use hal, and wacom-tools has been replaced by a new driver…

well I have had trouble since 8.10, and still persists in 9.10, with blender. and that happens also with 2.5. Strange thing is gimp or inkscape work perfectly all time.

Frigge, that’s right and good to hear it’s fixed!

both gimp and inkscape require you to “configure input devices” so you can manually choose the wacom, whatever it’s called…

2.4x expects inputs to be called"stylus" or it won’t work…

2.5 has a new system that works better…(that I don’t know how it detects a graphics tablet…)

there were some threads here about customising your fdi files for hal…(back when it first got used rather than xorg.conf)

Well I have now updated to the actual RC of kubuntu 10.04 and tested my wacom graphire4 with the following applications:

blender 2.5
blender 2.49b

The system is a clean fresh install (no update) and gives the following results:

blender 2.5: works without problems including pressure sensitivity
blender 2.49b: works as mouse but without pressure sensitivity
gimp: works after activating the wacom in the preferences dialog
mypaint: works perfectly

That means, its the same as 9.10 regarding the behavior it exhibits.

Its said that lucid replaced hal with devicekit, so I didn’t expect to find any fdi files where previously you could do hacks to get the wacom working with blender 2.49.
What puzzles me now is that there are fdi files and there is a hald daemon running. And there is no indication of devicekit being actually used.
That doesn’t help though, as the hacks used previously are not longer directly applicable, as the fdi files where you put the hacks in are no longer existent.

It will be interesting to see how I will get the pressure sensitivity working with 10.04 and blender 2.49 :spin:

this story just never ends …:rolleyes:

loramel, does wacomcpl work?

Michael, hard to say as wacom-tools package seems to be no longer available for 10.04. You still are able to use xsetwacom to set the values by hand.

i just upgraded to 10.4 release candidate before i read your post.

out of curiosity i took my wacom bamboo (an older one: CTE-650) which usually works great on my other machine (arch linux / win7) and tested it on my ubuntu laptop.

it worked flawlessly with mypaint and blender 2.5alpha2 (28154). no restart necessary. just plugged it in and it worked.

Never got wacom bamboo and pen working right in Ubuntu 9.1
So looking forward to trying it out in Ubuntu 10.
Hopefully it works because I’d rather not use Windows all the time :frowning:

i can confirm loramel’s experience.

after lots of rummaging about through various directories, poor documentation, and lots of forum posts, my opinion is that wacom support is almost there. almost.

wacomcpl does NOT work. xsetwacom does, if you know the parameters you are trying to set. ( visit LinuxWacomProject for details ) those settings are written to a file, ( .xinitrc, in your home directory ) which you can set to run at startup. too much effort, not enough function.

Well, it seems there is no ubuntu update with its share of wacom problems.

Currently the scroll wheel on my graphire4 tablet does not work anymore.

see here for more information.

At least a fix is to be expected …

Didnt bother to read all messages, but after initial problems it runs fine now. And the initial problem was due to my system being messy, from clean instal Wacom i3 should run fine.

I have Graphire3 and it works fine. I did xorg.conf editing and something else, minor (added one line to another file) and I works fine with sculpt and GIMP. I’ve never used mouse that comes with the tablet (don’t see a point of it), so I can’t tell ya if that works.

Wacom works really nicely for me, right out of the box in Ubuntu, since 9.10.

Better I guess with 10.04.

I have an old graphire to boot!

Now what I’d like to know is how well the Cintiq’s work, because I’d love to get my hands on one of those.