AO bake not working

I have a fully mapped object I’m trying to bake via ambient occlusion. It keeps saying ‘no object or image found to bake to’. I’ve tried selecting all the faces, also in object mode, and it always says this. Is this a bug or am I missing something?

Is a texture assigned to it in the UV/Image Editor when you’re in edit mode and select all the faces of your model ?

Hmm, I don’t use that function but isn’t it that you just need to create the (blank) image in the image editor (and save it?) before baking?

To be more clear, Bake has always worked for me if a texture is assigned to an unwrapped model , as seen when if in the Edit Mode, you select the whole model and see that the UV map in UV/Image Editor appears to be on the actual texture
http://i.imgur.com/MiTeQ.jpg

Now if in edit mode when i select my unwrapped model, i can see that on the UV/Image Editor that the uv map appear on top of no texture, it means there’s no texture assigned :
http://i.imgur.com/CfTjU.jpg

Then the “no object or image found to bake to” error message will popup.

If you had created a texture already, the problem may be that it’s just not assigned, so in that case just select your texture in the image browser to assign it and the bake function should work again :
http://i.imgur.com/JvrAC.jpg

Well yes the image is assigned, I’m looking at it checkered in the texture view port. I should say that i haven’t had problems AO baking in the past, it’s just happening now with this model. Are there any other scenarios where it will refuse to bake it?

I remember now having read about someone having this problem despite he was having everything apparently correctly setup.
His problem was in the outliner, the object had the “Restrict Renderability” setting, that was the source of the problem , as to bake an object must be able to be rendered.

Well you’re the man, that option was on for some reason. Works now, thanks.