AO in Cycles

So there’s AO in Cycles but, seriously, anyone got it going, hehe? Either they just implemented the buttons/settings or I’m missing something crucial, hehe… :eyebrowlift: (like a brain)

I thought AO was just built in by default. Basically delete all lights in the scene and use the world background color chit as the brightness of the AO. Samples are controlled in the integrator.

Is there some other node setup floating around…?

Attachments




Just set the energy to 0 and add it to the scene via the compositor.

For one thing, you will still get a working AO pass even if the energy is 0, using the AO pass in the compositor would also allow you to multiply it onto the image as well as have that multiplication be affected by light levels (direct, indirect, or both).

AO (as a real phenomenon) occurs in reality but AO (in renderers) is a system for faking it. Some renderers can replicate AO though, without faking it, through GI/photon mapping and alike… I don’t know how well Cycles replicates it, but what I’m talking about is the function for faking it. :slight_smile:

Thanks. Seems I had it going but I didn’t realize as it doesen’t render as a layer. Tried both ‘AO’ and’ Enviroment’ under render tab/layers but both render as solid black. Any ideas to why?

What is the scale of your scene, if it’s an interior scene using a small scale in Blender units and you have the value too high than everything will be considered fully occluded, try lowering it a bit if this is the case.

Hmm, that’s not the problem, I do see the occlusion but it doesn’t seem like I can get it to render separately, seems it automagically renders on top. I want it as a separate renderpass so I can control it in comp. When I activate the AO pass it just renders to black, so what am I missing?

You set the ‘Factor’ slider to zero didn’t you? I’ve been able to still get a working AO pass with it set that way since it was implemented.

Checked now and now, seems I had it at 0.05 - but makes no difference setting it to 0 though, still render the AO as pure black… I’m just lost in, am I missing something or does it just not render it? I hate that feeling, not knowing who’s at fault, you or the software. ;D

Edit: Also tried rendering AO only on a separate layer, no luck there either…

AO on GPU only with Shader Language 2.0 +. On my Macbook Pro 6.2 with Gt330M it doesn’t work, i’ve to use CPU Render. Might be your Problem as well.

It seems to work under Windows XP with CPU compute.

Attachments


Aaah, Bashi, that’s it… I’m on 1.3… (GTX285) Tnks, now I know it’s not me. :slight_smile:

Another sign it’s time to upgrade, though really want to wait for the GTX680 - 1536 cores, hehe… :smiley:

Edit: Put the thread as ‘solved’ - Solution: AO in Cycles need shader model 2.0 to work.