AO weirdness

What’s going on here. I’ve attached 4 images.

They are a combination of shadows and/or Ambient occlusion being on or off.

1 No shadows or AO = What I would expect.
2 No shadows but AO on = Yikes its all black. Not what I would expect at all
3 Shadows on and AO off = Well it basically looks like AO is still on.
4 Shadows on and AO on = Seems to confirm my suspicions about 3 as it’s identical, indicating that AO is on when shadows are on.

Is this a bug, does it happen to anyone else?
I’m 64bit ubuntu.

And I use 2 direction lights and a sky texture hdri probe to light the scene.


last image


Maybe duplicate the file, delete the head, throw in a block and upload a .blend file to look at.

I can’t pack the light probe so you’l have to download it. Its the uffizi_probe.hdr you can get it here.

Ok so it’s definitely got something to do with the environment lighting. The issue seems to resolve if it’s turned off.
So try turning off shadows and rendering.


aoprob1.blend (204 KB)

This is what mine renders out to.[ATTACH=CONFIG]121137[/ATTACH]

Is that with shadows off?

[ATTACH=CONFIG]121141[/ATTACH]That was Shadows on, AO on.
Here is Shadows off, AO on, Sky box checked in Layers

I added the Reflecting ball in there.

Ok it’s difficult to tell from that. Can you render the scene I posted without changing anything, except turning shadows off, please.

When I do that I get this.


Shadows off.[ATTACH=CONFIG]121145[/ATTACH]