Append failure: Not a library?

I’ve encountered a couple of puzzling situations I’d like to ask about:

  1. Under what circumstances could an object become “Not a library” for the purposes of appending? I wanted to update an earlier version of a .blend with one object (simple mesh, a plane, with simple animation) from a later version, which had been only slightly altered (a few keys moved in a set of IPO curves, and some minor sculpting to the mesh), but was given a error message: “Not a library!” when attempting to append the object. I was able to append the object’s Mesh, which was useful for the sculpting changes, but not the IPOs.

Oddly enough, I was able to append the object from the version of the .blend immediately prior to that which gave the error message – yet the object hadn’t change between those versions! To clarify: Append the object from version 10 to version 8 – error (“Not a library”). Append from version 9 to version 8 – successful. Changes between version 9 and 10 – none on that object.

In fact, all my attempts to append an object from version 10 to version 8 got the same error message (though I did not attempt to append all version 10’s objects).

  1. This isn’t necessarily interface related, but involves using the Compositor in a certain fashion.

I am using the Compositor to do both transitions and text supering (ala subtitling) on the rendered sequences from my movie. All works very, very well in general, but in the first session, I ran into a crash due to memory overload – somehow, the Mem usage report in the window had jumped to better than a gig! I was able to recover OK, but in watching closely from then on, I realized that with nearly every move from one frame to another in the compositor, monitoring the output via the “Always refresh images on frame changes” option and various Viewer nodes, the Mem usage went up a bit. The more times I changed frames, the greater the Mem usage. It only very rarely went down, and then only a small amount. The cumulative increase was much greater. Eventually, the Mem usage would reach my system’s “wall” and start making probs. Quit and reopen (with much smaller Mem usage) and the cycle starts again.

I’m unfamiliar with how the Compositor works on this level, but this sounds to me like a possible memory leak. Any second opinions or enlightenments?