Append is greyed

I appended a head to my project, modeled it a bit, and now I want to append an eyeball, but Shift F1 is not working and Append in the file menu is greyed out.

What would cause this?

Also, when I tried to add a sphere to my project (instead of the eyeball), I seem to have gotten two spheres. One wire mesh, the other solid, I think. When I press G, both move toward each other when I move the mouse.

Why is that?

Sounds like you are in edit mode when trying to append and object. Hit tab first to change from edit to object mode, then the append menu should work again.

The sphere you added might have also been added in edit mode to an existing mesh that has a mirror modifier. If you add something in edit mode, you are making it a part of the mesh you are currently editing. And if this mesh has a mirror modifier, any added geometry will be subject to that as well and gets duplicated. Maybe that’s what you’re seeing.

Here’s some info:
Object/Edit mode
Mirror modifier

Thanks, Sanne, that is exactly what the problem was. Both problems solved, heh.

And the thanks for the great links!

Great to hear, and you’re welcome, JonnyRelentless. :slight_smile: